• 全排列


    Now our hero finds the door to the BEelzebub feng5166. He opens the door and finds feng5166 is about to kill our pretty Princess. But now the BEelzebub has to beat our hero first. feng5166 says, "I have three question for you, if you can work them out, I will release the Princess, or you will be my dinner, too." Ignatius says confidently, "OK, at last, I will save the Princess." 

    "Now I will show you the first problem." feng5166 says, "Given a sequence of number 1 to N, we define that 1,2,3...N-1,N is the smallest sequence among all the sequence which can be composed with number 1 to N(each number can be and should be use only once in this problem). So it's easy to see the second smallest sequence is 1,2,3...N,N-1. Now I will give you two numbers, N and M. You should tell me the Mth smallest sequence which is composed with number 1 to N. It's easy, isn't is? Hahahahaha......" 
    Can you help Ignatius to solve this problem? 
    InputThe input contains several test cases. Each test case consists of two numbers, N and M(1<=N<=1000, 1<=M<=10000). You may assume that there is always a sequence satisfied the BEelzebub's demand. The input is terminated by the end of file. 
    OutputFor each test case, you only have to output the sequence satisfied the BEelzebub's demand. When output a sequence, you should print a space between two numbers, but do not output any spaces after the last number. 
    Sample Input
    6 4
    11 8
    Sample Output
    1 2 3 5 6 4
    1 2 3 4 5 6 7 9 8 11 10

    利用STL里面的next_permutation()做这道题不要太简单。。

    #include<iostream>
    #include<algorithm>
    using namespace std;
    #define N 1005
    void permutation(int *a,int length,int end)
    {
        int count=0;
        sort(a,a+length);
        do
        {
            count++;
            if(count==end)
                {
                    for(int i=0;i<length;i++)
                        {
                            if(i==length-1)
                                cout<<a[i];
                            else
                                cout<<a[i]<<" ";
                        }
                    break;
                }
        }
        while(next_permutation(a,a+length));
    }
    int main()
    {
        int x,a[N],y;
        while(cin>>x>>y)
        {
            for(int i=0;i<x;i++)
                a[i]=i+1;
            permutation(a,x,y);
            cout<<endl;
        }
        return 0;
    }
    

      

  • 相关阅读:
    Postman:Pre-request Script
    PHP修改脚本最大执行时间和最大内存限制
    PHP函数:array_chunk
    PHP出现SSL certificate:unable to get local issuer certificate的解决办法
    Linux命令:chown
    PHP函数:fopen
    PHP常量:JSON_UNESCAPED_UNICODE
    Android -- 贝塞尔曲线公式的推导和简单使用
    Java -- 浅入Java反射机制
    Java -- 深入浅出GC自动回收机制
  • 原文地址:https://www.cnblogs.com/zzzying/p/7202226.html
Copyright © 2020-2023  润新知