• 洛谷P2895 [USACO08FEB]流星雨Meteor Shower


    题目描述

    Bessie hears that an extraordinary meteor shower is coming; reports say that these meteors will crash into earth and destroy anything they hit. Anxious for her safety, she vows to find her way to a safe location (one that is never destroyed by a meteor) . She is currently grazing at the origin in the coordinate plane and wants to move to a new, safer location while avoiding being destroyed by meteors along her way.

    The reports say that M meteors (1 ≤ M ≤ 50,000) will strike, with meteor i will striking point (Xi, Yi) (0 ≤ Xi ≤ 300; 0 ≤ Yi ≤ 300) at time Ti (0 ≤ Ti  ≤ 1,000). Each meteor destroys the point that it strikes and also the four rectilinearly adjacent lattice points.

    Bessie leaves the origin at time 0 and can travel in the first quadrant and parallel to the axes at the rate of one distance unit per second to any of the (often 4) adjacent rectilinear points that are not yet destroyed by a meteor. She cannot be located on a point at any time greater than or equal to the time it is destroyed).

    Determine the minimum time it takes Bessie to get to a safe place.

    牛去看流星雨,不料流星掉下来会砸毁上下左右中五个点。每个流星掉下的位置和时间都不同,求牛能否活命,如果能活命,最短的逃跑时间是多少?

    输入输出格式

    输入格式:

     

    • Line 1: A single integer: M

    • Lines 2..M+1: Line i+1 contains three space-separated integers: Xi, Yi, and Ti

     

    输出格式:

     

    • Line 1: The minimum time it takes Bessie to get to a safe place or -1 if it is impossible.

     

    输入输出样例

    输入样例#1:
    4
    0 0 2
    2 1 2
    1 1 2
    0 3 5
    
    输出样例#1:
    5

    题目大意:从(0,0)出发,每个点在一定时间内会被炸,求逃生的最短时间。
    题解:预处理每个点被炸时间,bfs
    代码:
    #include<iostream>
    #include<cstdio>
    #include<cstring>
    #include<queue>
    using namespace std;
    
    int n,map[450][450],dis[450][450];
    int mx[4]={0,1,-1,0},
        my[4]={1,0,0,-1};
    struct node{
        int x,y;
    };
    queue<node>q;
    
    int main(){
        scanf("%d",&n);
        memset(map,0x3f,sizeof(map));
        for(int i=1;i<=n;i++){
            int x,y,t;
            scanf("%d%d%d",&x,&y,&t);
            map[x][y]=min(map[x][y],t);
            for(int j=0;j<4;j++){
                int xx=x+mx[j],yy=y+my[j];
                if(xx<0||yy<0)continue;
                map[xx][yy]=min(map[xx][yy],t);
            }
        }
        memset(dis,0x3f,sizeof(dis));
        dis[0][0]=0;node a;a.x=0;a.y=0;
        q.push(a);
        while(!q.empty()){
            node now=q.front();q.pop();
            if(map[now.x][now.y]==0x3f3f3f3f){
                cout<<dis[now.x][now.y];
                return 0;
            }
            int x=now.x,y=now.y;
            for(int i=0;i<4;i++){
                int xx=x+mx[i],yy=y+my[i];
                if(xx<0||yy<0||map[xx][yy]<=dis[x][y]+1)continue;
                if(dis[xx][yy]<=dis[x][y]+1) continue;
                if(dis[xx][yy]>=dis[x][y]+1){
                    dis[xx][yy]=dis[x][y]+1;
                    node b;b.x=xx;b.y=yy;
                    q.push(b);
                }
            }
        }
        puts("-1");
        return 0;
    }
     
  • 相关阅读:
    阿里云的使用运维安装
    阿里云的使用运维安装
    promis:异步编程
    promis:异步编程
    微信开发笔记
    细数那些带打赏功能的平台
    细数那些带打赏功能的平台
    Java Web Services (0)
    4、查询(2)
    COGS——C610. 数对的个数
  • 原文地址:https://www.cnblogs.com/zzyh/p/7603074.html
Copyright © 2020-2023  润新知