• hdu 1385 floyd字典序


    Minimum Transport Cost

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 11017    Accepted Submission(s): 3058


    Problem Description
    These are N cities in Spring country. Between each pair of cities there may be one transportation track or none. Now there is some cargo that should be delivered from one city to another. The transportation fee consists of two parts:
    The cost of the transportation on the path between these cities, and

    a certain tax which will be charged whenever any cargo passing through one city, except for the source and the destination cities.

    You must write a program to find the route which has the minimum cost.
     
    Input
    First is N, number of cities. N = 0 indicates the end of input.

    The data of path cost, city tax, source and destination cities are given in the input, which is of the form:

    a11 a12 ... a1N
    a21 a22 ... a2N
    ...............
    aN1 aN2 ... aNN
    b1 b2 ... bN

    c d
    e f
    ...
    g h

    where aij is the transport cost from city i to city j, aij = -1 indicates there is no direct path between city i and city j. bi represents the tax of passing through city i. And the cargo is to be delivered from city c to city d, city e to city f, ..., and g = h = -1. You must output the sequence of cities passed by and the total cost which is of the form:
     
    Output
    From c to d :
    Path: c-->c1-->......-->ck-->d
    Total cost : ......
    ......

    From e to f :
    Path: e-->e1-->..........-->ek-->f
    Total cost : ......

    Note: if there are more minimal paths, output the lexically smallest one. Print a blank line after each test case.

     
    Sample Input
    5 0 3 22 -1 4 3 0 5 -1 -1 22 5 0 9 20 -1 -1 9 0 4 4 -1 20 4 0 5 17 8 3 1 1 3 3 5 2 4 -1 -1 0
     
    Sample Output
    From 1 to 3 : Path: 1-->5-->4-->3 Total cost : 21 From 3 to 5 : Path: 3-->4-->5 Total cost : 16 From 2 to 4 : Path: 2-->1-->5-->4 Total cost : 17
     
    Source
     disguss里给的某些数据根本就是错的吧。。我的错误一开始是变量写错结果对着他们的test改半天ccc。一直死循环
    floyd不必多数,字典序得话,肯定有最前面的字母决定总体的大小,所以path[i][j]表示i-->j中间经过的第一个点
    还有就是单向图这个我倒是没写错。

    #include<bits/stdc++.h>
    using namespace std;
    #define inf 0x3f3f3f3f
    #define ql(a,b) memset(a,b,sizeof(a))
    int e[105][105],b[105];
    int path[105][105];
    void floyd(int n)
    {
    int i,j,k;
    for(k=1;k<=n;++k)
    for(i=1;i<=n;++i)
    for(j=1;j<=n;++j){
    if(e[i][j]>b[k]+e[i][k]+e[k][j]){
    e[i][j]=b[k]+e[i][k]+e[k][j];
    path[i][j]=path[i][k];
    }
    else if(e[i][j]==b[k]+e[i][k]+e[k][j]&&path[i][j]>path[i][k]){
    path[i][j]=path[i][k];
    }
    }
    }
    void print(int u,int v)
    {
    int k;
    if(u==v)
    {
    printf("%d",v);
    return ;
    }
    k=path[u][v];
    printf("%d-->",u);
    print(k,v);
    }
    int main()
    {
    int n,m,i,j,k,a,c,t=1;
    while(cin>>n&&n){
    for(i=1;i<=n;++i)
    for(j=1;j<=n;++j){
    scanf("%d",&e[i][j]);
    if(e[i][j]==-1) e[i][j]=inf;
    path[i][j]=j;
    }
    for(i=1;i<=n;++i) cin>>b[i];
    floyd(n);
    while(cin>>a>>c&&(a+1||c+1)){
    printf("From %d to %d : Path: ",a,c);
    print(a,c);
    printf(" Total cost : %d ",e[a][c]);
    }
    }
    return 0;
    }

     
  • 相关阅读:
    hdu1074Doing Homework
    1088滑雪
    hdu1078FatMouse and Cheese
    hdu1058Humble Numbers
    hdu1114 Piggy-Bank
    hdu1069Monkey and Banana
    未解决的问题_c#中,最小化触发事件
    WPF Button 样式资源设置&后台生成button样式
    .NET 调用外部exe程序,出现已停止工作
    json类序列化与反序列化参考
  • 原文地址:https://www.cnblogs.com/zzqc/p/6945873.html
Copyright © 2020-2023  润新知