• hdu2955(概率DP)


    The aspiring Roy the Robber has seen a lot of American movies, and knows that the bad guys usually gets caught in the end, often because they become too greedy. He has decided to work in the lucrative business of bank robbery only for a short while, before retiring to a comfortable job at a university.


    For a few months now, Roy has been assessing the security of various banks and the amount of cash they hold. He wants to make a calculated risk, and grab as much money as possible.


    His mother, Ola, has decided upon a tolerable probability of getting caught. She feels that he is safe enough if the banks he robs together give a probability less than this.
     
    Input
    The first line of input gives T, the number of cases. For each scenario, the first line of input gives a floating point number P, the probability Roy needs to be below, and an integer N, the number of banks he has plans for. Then follow N lines, where line j gives an integer Mj and a floating point number Pj .
    Bank j contains Mj millions, and the probability of getting caught from robbing it is Pj .
     
    Output
    For each test case, output a line with the maximum number of millions he can expect to get while the probability of getting caught is less than the limit set.

    Notes and Constraints
    0 < T <= 100
    0.0 <= P <= 1.0
    0 < N <= 100
    0 < Mj <= 100
    0.0 <= Pj <= 1.0
    A bank goes bankrupt if it is robbed, and you may assume that all probabilities are independent as the police have very low funds.
     
    Sample Input
    3 0.04 3 1 0.02 2 0.03 3 0.05 0.06 3 2 0.03 2 0.03 3 0.05 0.10 3 1 0.03 2 0.02 3 0.05
     
    Sample Output
    2 4 6
     
    给出一个临街概率,求被抓概率不超过此概率的情况下能抢到的最大价值;
    由于题目给出的是被抓概率,计算起来没有成功概率方便,我们不妨将失败概率转化为成功概率计算更加容易;
    DP[i]:抢到i价值成功的最大概率,不同于背包的一点是,有点“必须装满的感觉”,就是这个i必须要能够被给出的几个价值组合成才可,所以初始化概率为0(dp[0]=1)
    {背包:dp[i]:背包大小为i时能获得的最大价值,这道题的话,只要价值无法被组成概率就是0,就是没有固定背包大小,《背包大小成了要求的未知数》!!!
    但又多了一重要求:概率要小于给定概率;}
     
    综上此题要求的是:在概率满足题目要求的情况下,由给定的几个’物品‘所能组成的最大价值!!!
     
     
    代码:

    #include<bits/stdc++.h>
    using namespace std;
    double dp[10005]; //x下标表示能抢够这个金钱的概率
    int main()
    {
    int T,N,m[105],n,i,j,k,max_money;
    double P,p[105];
    cin>>T;
    while(T--){memset(dp,0,sizeof(dp));
    dp[0]=1,max_money=0;
    cin>>P>>N;
    for(i=1;i<=N;++i) {
    cin>>m[i]>>p[i];
    p[i]=1.0-p[i];
    max_money+=m[i];
    }
    for(i=1;i<=N;++i)
    for(j=max_money;j>=m[i];--j)
    dp[j]=max(dp[j],dp[j-m[i]]*p[i]);
    for(i=max_money;i>=0;--i) if(dp[i]>1-P||i==0) {cout<<i<<endl;break;}
    }
    return 0;
    }

  • 相关阅读:
    xgqfrms™, xgqfrms® : xgqfrms's offical website of GitHub!
    xgqfrms™, xgqfrms® : xgqfrms's offical website of GitHub!
    xgqfrms™, xgqfrms® : xgqfrms's offical website of GitHub!
    xgqfrms™, xgqfrms® : xgqfrms's offical website of GitHub!
    xgqfrms™, xgqfrms® : xgqfrms's offical website of GitHub!
    xgqfrms™, xgqfrms® : xgqfrms's offical website of GitHub!
    scala 时间,时间格式转换
    GIS基础知识
    客户端,Scala:Spark查询Phoenix
    Phoenix的shell操作
  • 原文地址:https://www.cnblogs.com/zzqc/p/6618255.html
Copyright © 2020-2023  润新知