• CF1101A Minimum Integer 模拟


    题意翻译

    题意简述

    给出qqq组询问,每组询问给出l,r,dl,r,dl,r,d,求一个最小的正整数xxx满足d∣x d | x dx 且x̸∈[l,r] x otin [l,r]x̸[l,r]

    输入格式

    第一行一个正整数q(1≤q≤500)q(1 leq q leq 500)q(1q500)

    接下来qqq行每行三个正整数l,r,d(1≤l≤r≤109,1≤d≤109)l,r,d(1 leq l leq r leq 10^9 , 1 leq d leq 10^9)l,r,d(1lr109,1d109)表示一组询问

    输出格式

    对于每一组询问输出一行表示答案

    题目描述

    You are given q q q queries in the following form:

    Given three integers li l_i li , ri r_i ri and di d_i di , find minimum positive integer xi x_i xi such that it is divisible by di d_i di and it does not belong to the segment [li,ri] [l_i, r_i] [li,ri] .

    Can you answer all the queries?

    Recall that a number x x x belongs to segment [l,r] [l, r] [l,r] if l≤x≤r l le x le r lxr .

    输入输出格式

    输入格式:

    The first line contains one integer q q q ( 1≤q≤500 1 le q le 500 1q500 ) — the number of queries.

    Then q q q lines follow, each containing a query given in the format li l_i li ri r_i ri di d_i di ( 1≤li≤ri≤109 1 le l_i le r_i le 10^9 1liri109 , 1≤di≤109 1 le d_i le 10^9 1di109 ). li l_i li , ri r_i ri and di d_i di​ are integers.

    输出格式:

    For each query print one integer: the answer to this query.

    输入输出样例

    输入样例#1: 复制
    5
    2 4 2
    5 10 4
    3 10 1
    1 2 3
    4 6 5
    
    输出样例#1: 复制
    6
    4
    1
    3
    10
    
    #include<iostream>
    #include<cstdio>
    #include<algorithm>
    #include<cstdlib>
    #include<cstring>
    #include<string>
    #include<cmath>
    #include<map>
    #include<set>
    #include<vector>
    #include<queue>
    #include<bitset>
    #include<ctime>
    #include<deque>
    #include<stack>
    #include<functional>
    #include<sstream>
    //#include<cctype>
    //#pragma GCC optimize(2)
    using namespace std;
    #define maxn 100005
    #define inf 0x7fffffff
    //#define INF 1e18
    #define rdint(x) scanf("%d",&x)
    #define rdllt(x) scanf("%lld",&x)
    #define rdult(x) scanf("%lu",&x)
    #define rdlf(x) scanf("%lf",&x)
    #define rdstr(x) scanf("%s",x)
    typedef long long  ll;
    typedef unsigned long long ull;
    typedef unsigned int U;
    #define ms(x) memset((x),0,sizeof(x))
    const long long int mod = 1e9 + 7;
    #define Mod 1000000000
    #define sq(x) (x)*(x)
    #define eps 1e-4
    typedef pair<int, int> pii;
    #define pi acos(-1.0)
    //const int N = 1005;
    #define REP(i,n) for(int i=0;i<(n);i++)
    typedef pair<int, int> pii;
    inline ll rd() {
        ll x = 0;
        char c = getchar();
        bool f = false;
        while (!isdigit(c)) {
            if (c == '-') f = true;
            c = getchar();
        }
        while (isdigit(c)) {
            x = (x << 1) + (x << 3) + (c ^ 48);
            c = getchar();
        }
        return f ? -x : x;
    }
    
    ll gcd(ll a, ll b) {
        return b == 0 ? a : gcd(b, a%b);
    }
    int sqr(int x) { return x * x; }
    
    
    /*ll ans;
    ll exgcd(ll a, ll b, ll &x, ll &y) {
        if (!b) {
            x = 1; y = 0; return a;
        }
        ans = exgcd(b, a%b, x, y);
        ll t = x; x = y; y = t - a / b * y;
        return ans;
    }
    */
    
    int q;
    ll l, r, d;
    
    int main() {
        ios::sync_with_stdio(0);
        cin >> q;
        while (q--) {
            cin >> l >> r >> d;
            ll L, R;
            if (l%d != 0) {
                L = (l / d);
            }
            else if (l%d == 0)L = l / d - 1;
            if (r%d == 0)R = r / d + 1;
            else if (r%d != 0)R = r / d + 1;
            if (L == 0) {
                cout << d * R << endl;
            }
            else {
                cout << 1 * d << endl;
            }
        }
        return 0;
    }
    
    EPFL - Fighting
  • 相关阅读:
    __all__
    python内置函数
    qZnF新存马王至许观制两利各
    PHP中获取当前页面的完整URL
    DedeCms用tag调用全站相关文章
    dedecms如何利用tag来调取相关文章
    SQL Server TempDB
    SQL Server Pivot 隐藏group
    Rebind and Rewind in Execution Plans
    batch 数字进制的问题
  • 原文地址:https://www.cnblogs.com/zxyqzy/p/10275693.html
Copyright © 2020-2023  润新知