• [JLOI2012]树 倍增优化


    题目描述

    在这个问题中,给定一个值S和一棵树。在树的每个节点有一个正整数,问有多少条路径的节点总和达到S。路径中节点的深度必须是升序的。假设节点1是根节点,根的深度是0,它的儿子节点的深度为1。路径不必一定从根节点开始。

    输入输出格式

    输入格式:

    第一行是两个整数N和S,其中N是树的节点数。 第二行是N个正整数,第i个整数表示节点i的正整数。 接下来的N-1行每行是2个整数x和y,表示y是x的儿子。

    输出格式:

    输出路径节点总和为S的路径数量。

    输入输出样例

    输入样例#1: 复制
    3 3
    1 2 3
    1 2
    1 3
    输出样例#1: 复制
    2

    说明

    对于100%数据,N<=100000,所有权值以及S都不超过1000。

    倍增;

    #include<iostream>
    #include<cstdio>
    #include<algorithm>
    #include<cstdlib>
    #include<cstring>
    #include<string>
    #include<cmath>
    #include<map>
    #include<set>
    #include<vector>
    #include<queue>
    #include<bitset>
    #include<ctime>
    #include<deque>
    #include<stack>
    #include<functional>
    #include<sstream>
    //#include<cctype>
    //#pragma GCC optimize(2)
    using namespace std;
    #define maxn 1000005
    #define inf 0x7fffffff
    //#define INF 1e18
    #define rdint(x) scanf("%d",&x)
    #define rdllt(x) scanf("%lld",&x)
    #define rdult(x) scanf("%lu",&x)
    #define rdlf(x) scanf("%lf",&x)
    #define rdstr(x) scanf("%s",x)
    typedef long long  ll;
    typedef unsigned long long ull;
    typedef unsigned int U;
    #define ms(x) memset((x),0,sizeof(x))
    const long long int mod = 1e9 + 7;
    #define Mod 1000000000
    #define sq(x) (x)*(x)
    #define eps 1e-3
    typedef pair<int, int> pii;
    #define pi acos(-1.0)
    //const int N = 1005;
    #define REP(i,n) for(int i=0;i<(n);i++)
    typedef pair<int, int> pii;
    inline ll rd() {
    	ll x = 0;
    	char c = getchar();
    	bool f = false;
    	while (!isdigit(c)) {
    		if (c == '-') f = true;
    		c = getchar();
    	}
    	while (isdigit(c)) {
    		x = (x << 1) + (x << 3) + (c ^ 48);
    		c = getchar();
    	}
    	return f ? -x : x;
    }
    
    ll gcd(ll a, ll b) {
    	return b == 0 ? a : gcd(b, a%b);
    }
    int sqr(int x) { return x * x; }
    
    
    /*ll ans;
    ll exgcd(ll a, ll b, ll &x, ll &y) {
    	if (!b) {
    		x = 1; y = 0; return a;
    	}
    	ans = exgcd(b, a%b, x, y);
    	ll t = x; x = y; y = t - a / b * y;
    	return ans;
    }
    */
    int n, m;
    int val[maxn][20];
    int fa[maxn][20];
    
    
    int main() {
    	//ios::sync_with_stdio(0);
    	rdint(n); rdint(m);
    	for (int i = 1; i <= n; i++) {
    		rdint(val[i][0]);
    	}
    	for (int i = 1; i < n; i++) {
    		int x, y; rdint(x); rdint(y);
    		fa[y][0] = x;
    	}
    	for (int i = 1; i <= 18; i++) {
    		for (int j = 1; j <= n; j++) {
    			fa[j][i] = fa[fa[j][i - 1]][i - 1];
    			val[j][i] = val[j][i - 1] + val[fa[j][i - 1]][i - 1];
    		}
    	}
    	int ans = 0;
    	for (int i = 1; i <= n; i++) {
    		int x = 0;
    		int y = i;
    		for (int j = 18; j >= 0; j--) {
    			if (x + val[y][j] <= m) {
    				x += val[y][j];
    				y = fa[y][j];
    			}
    			if (x == m) {
    				ans++; break;
    			}
    		}
    	}
    	cout << ans << endl;
    	return 0;
    }
    
    EPFL - Fighting
  • 相关阅读:
    Java NIO中的缓冲区Buffer(二)创建/复制缓冲区
    Java NIO中的缓冲区Buffer(一)缓冲区基础
    Java中的反射
    Java SE 9(JDK9)环境安装及交互式编程环境Jshell使用示例
    Spring Data JPA例子[基于Spring Boot、Mysql]
    Spring Session
    Spring Data Redis示例
    Spring IO Platform简介及示例
    使用Spring Boot开发 “Hello World” Web应用
    2017/01/13,今天正好是开通博客园一周年,谈谈自己的一些想法
  • 原文地址:https://www.cnblogs.com/zxyqzy/p/10260354.html
Copyright © 2020-2023  润新知