• Intervals POJ


    You are given n closed, integer intervals [ai, bi] and n integers c1, ..., cn.
    Write a program that:
    reads the number of intervals, their end points and integers c1, ..., cn from the standard input,
    computes the minimal size of a set Z of integers which has at least ci common elements with interval [ai, bi], for each i=1,2,...,n,
    writes the answer to the standard output.
    Input
    The first line of the input contains an integer n (1 <= n <= 50000) -- the number of intervals. The following n lines describe the intervals. The (i+1)-th line of the input contains three integers ai, bi and ci separated by single spaces and such that 0 <= ai <= bi <= 50000 and 1 <= ci <= bi - ai+1.
    Output
    The output contains exactly one integer equal to the minimal size of set Z sharing at least ci elements with interval [ai, bi], for each i=1,2,...,n.
    Sample Input
    5
    3 7 3
    8 10 3
    6 8 1
    1 3 1
    10 11 1
    Sample Output
    6
    #include<iostream>
    #include<cstdio>
    #include<algorithm>
    #include<cstdlib>
    #include<cstring>
    #include<string>
    #include<cmath>
    #include<map>
    #include<set>
    #include<vector>
    #include<queue>
    #include<bitset>
    #include<ctime>
    #include<deque>
    #include<stack>
    #include<functional>
    #include<sstream>
    //#include<cctype>
    //#pragma GCC optimize(2)
    using namespace std;
    #define maxn 200005
    #define inf 0x7fffffff
    //#define INF 1e18
    #define rdint(x) scanf("%d",&x)
    #define rdllt(x) scanf("%lld",&x)
    #define rdult(x) scanf("%lu",&x)
    #define rdlf(x) scanf("%lf",&x)
    #define rdstr(x) scanf("%s",x)
    typedef long long  ll;
    typedef unsigned long long ull;
    typedef unsigned int U;
    #define ms(x) memset((x),0,sizeof(x))
    const long long int mod = 1e9 + 7;
    #define Mod 1000000000
    #define sq(x) (x)*(x)
    #define eps 1e-3
    typedef pair<int, int> pii;
    #define pi acos(-1.0)
    //const int N = 1005;
    #define REP(i,n) for(int i=0;i<(n);i++)
    typedef pair<int, int> pii;
    inline ll rd() {
    	ll x = 0;
    	char c = getchar();
    	bool f = false;
    	while (!isdigit(c)) {
    		if (c == '-') f = true;
    		c = getchar();
    	}
    	while (isdigit(c)) {
    		x = (x << 1) + (x << 3) + (c ^ 48);
    		c = getchar();
    	}
    	return f ? -x : x;
    }
    
    ll gcd(ll a, ll b) {
    	return b == 0 ? a : gcd(b, a%b);
    }
    int sqr(int x) { return x * x; }
    
    
    /*ll ans;
    ll exgcd(ll a, ll b, ll &x, ll &y) {
    	if (!b) {
    		x = 1; y = 0; return a;
    	}
    	ans = exgcd(b, a%b, x, y);
    	ll t = x; x = y; y = t - a / b * y;
    	return ans;
    }
    */
    
    struct node {
    	int u, v, w;
    	int nxt;
    }edge[maxn];
    int head[maxn];
    int tot;
    int dis[maxn];
    bool vis[maxn];
    void addedge(int u, int v, int w) {
    	edge[++tot].u = u; edge[tot].v = v; edge[tot].w = w;
    	edge[tot].nxt = head[u]; head[u] = tot;
    }
    void spfa() {
    	queue<int>q;
    	q.push(0);
    	vis[0] = 1; dis[0] = 0;
    	while (!q.empty()) {
    		int u = q.front(); q.pop(); vis[u] = 0;
    		for (int i = head[u]; i; i = edge[i].nxt) {
    			int v = edge[i].v;
    			if (dis[v] < dis[u] + edge[i].w) {
    				dis[v] = dis[u] + edge[i].w;
    				if (!vis[v]) {
    					q.push(v); vis[v] = 1;
    				}
    			}
    		}
    	}
    }
    
    int main() {
    	//ios::sync_with_stdio(0);
    //	int T; rdint(T);
    //	while (T--) {
    		ms(head); memset(dis, -0x3f, sizeof(dis));
    		ms(vis); tot = 0;
    		int maxx = 0; int n;
    		cin >> n;
    		for (int i = 1; i <= n; i++) {
    			int a, b, c; rdint(a); rdint(b); rdint(c);
    			addedge(a, b + 1, c); maxx = max(maxx, b + 1);
    		}
    		for (int i = 1; i <= maxx; i++) {
    			addedge(i, i - 1, -1); addedge(i - 1, i, 0);
    		}
    		spfa();
    		cout << dis[maxx] << endl;
    //		if (T)cout << endl;
    //	}
    	return 0;
    }
    
    EPFL - Fighting
  • 相关阅读:
    Python数据分析的几种绘图方式——数据可视化(附源码)
    Python GUI项目实战:主窗体的界面设计与实现
    Python Scrapy框架:数据爬取全流程
    python来爬取煎蛋网随手拍小姐姐图片
    有意思的逻辑小练习:函数做参数进行传递
    python值*args和**kwargs的总结思考
    数据类型的基础知识补充,字典的并交集、空集合、可作为字典元组的元素、删除字典中的元素
    python里面为什么shell和保存文件运行结果不一样的相关思考(内存相关)
    代码:购物车(待修改)
    python里面为什么shell和保存文件运行结果不一样?
  • 原文地址:https://www.cnblogs.com/zxyqzy/p/10258919.html
Copyright © 2020-2023  润新知