• [USACO08OPEN]农场周围的道路Roads Around The Farm BZOJ 1621 DFS


    Farmer John's cows have taken an interest in exploring the territory around the farm. Initially, all N (1 <= N <= 1,000,000,000) cows commence traveling down a road in one big group. Upon encountering a fork in the road, the group sometimes chooses to break into two smaller (nonempty) groups with each group continuing down one of the roads. When one of those groups arrives at another fork, it might split again, and so on. The cows have crafted a peculiar way of splitting: if they can split into two groups such that the sizes of the groups differ by exactly K (1 <= K <= 1000), then they will split in that way; otherwise, they stop exploring and just start grazing peacefully. Assuming that there will always be new forks in the road, compute the final number of groups of peacefully grazing cows. N个牛走路,遇到分叉,如果能分成人数之差为K的两堆,则分头行进. 否则就不走了.问最多分成几个块.
    Input
    * Line 1: Two space-separated integers: N and K
    Output
    * Line 1: A single integer representing the number of groups of grazing cows
    Sample Input
    6 2

    INPUT DETAILS:

    There are 6 cows and the difference in group sizes is 2.

    Sample Output
    3

    OUTPUT DETAILS:

    There are 3 final groups (with 2, 1, and 3 cows in them).

    6
    /
    2 4
    /
    1 3


    直接dfs就行了;
    #include<iostream>
    #include<cstdio>
    #include<algorithm>
    #include<cstdlib>
    #include<cstring>
    #include<string>
    #include<cmath>
    #include<map>
    #include<set>
    #include<vector>
    #include<queue>
    #include<bitset>
    #include<ctime>
    #include<deque>
    #include<stack>
    #include<functional>
    #include<sstream>
    
    //#include<cctype>
    //#pragma GCC optimize("O3")
    using namespace std;
    #define maxn 300005
    #define inf 0x3f3f3f3f
    #define INF 9999999999
    #define rdint(x) scanf("%d",&x)
    #define rdllt(x) scanf("%lld",&x)
    #define rdult(x) scanf("%lu",&x)
    #define rdlf(x) scanf("%lf",&x)
    #define rdstr(x) scanf("%s",x)
    typedef long long  ll;
    typedef unsigned long long ull;
    typedef unsigned int U;
    #define ms(x) memset((x),0,sizeof(x))
    const long long int mod = 1e9 + 7;
    #define Mod 1000000000
    #define sq(x) (x)*(x)
    #define eps 1e-3
    typedef pair<int, int> pii;
    #define pi acos(-1.0)
    //const int N = 1005;
    #define REP(i,n) for(int i=0;i<(n);i++)
    
    inline ll rd() {
    	ll x = 0;
    	char c = getchar();
    	bool f = false;
    	while (!isdigit(c)) {
    		if (c == '-') f = true;
    		c = getchar();
    	}
    	while (isdigit(c)) {
    		x = (x << 1) + (x << 3) + (c ^ 48);
    		c = getchar();
    	}
    	return f ? -x : x;
    }
    
    ll gcd(ll a, ll b) {
    	return b == 0 ? a : gcd(b, a%b);
    }
    ll sqr(ll x) { return x * x; }
    
    /*ll ans;
    ll exgcd(ll a, ll b, ll &x, ll &y) {
    	if (!b) {
    		x = 1; y = 0; return a;
    	}
    	ans = exgcd(b, a%b, x, y);
    	ll t = x; x = y; y = t - a / b * y;
    	return ans;
    }
    */
    
    
    
    ll qpow(ll a, ll b, ll c) {
    	ll ans = 1;
    	a = a % c;
    	while (b) {
    		if (b % 2)ans = ans * a%c;
    		b /= 2; a = a * a%c;
    	}
    	return ans;
    }
    
    int n, k;
    int ans;
    
    void dfs(int cursum) {
    	if ((cursum + k) % 2 == 1 || (cursum - k) % 2 == 1 || cursum <= k) {
    		ans++;
    		return;
    	}
    	
    	if ((cursum + k) % 2 == 0) {
    		
    		dfs((cursum + k) / 2);
    
    	}
    	if ((cursum - k) % 2 == 0) {
    		dfs((cursum - k) / 2);
    	}
    	
    }
    
    int main()
    {
    	//ios::sync_with_stdio(0);
    	rdint(n); rdint(k);
    	dfs(n);
    	cout << ans << endl;
        return 0;
    }
    

    EPFL - Fighting
  • 相关阅读:
    Dockerfile指令
    oracle--ORA-38760
    守护进程--Supervisor
    oracle--sqlplus格式化输出
    oracle--10.2.0.3升级到11.2.0.4
    oracle--ORA-27125
    oracle--10安装问题
    oracle--CKPT
    oracle--LGWR
    Oracle--SMON
  • 原文地址:https://www.cnblogs.com/zxyqzy/p/10033786.html
Copyright © 2020-2023  润新知