• POJ 2114 Boatherds 树分治


    Boatherds
     
     

    Description

     

    Boatherds Inc. is a sailing company operating in the country of Trabantustan and offering boat trips on Trabantian rivers. All the rivers originate somewhere in the mountains and on their way down to the lowlands they gradually join and finally the single resulting river flows to the sea. Moreover, the Trabantian villages are exactly at the rivers' springs, junctions and at the mouth of the largest river. Please note that more than 2 rivers can join at a junction. However, the rivers always form a tree (with villages as vertices). 

    The pricing policy of the Boatherds is very simple: each segment of each river between two villages is assigned a price (the price is same in both directions), so if a tourist requests a journey between any two villages, the ticket office clerks just add the prices of the segments along the only path between the villages. 

    One day, a very strange tourist appeared. She told the clerks that she returns to her country on the next day and she wants to spend all the remaining money on a boat trip, so they should find a route with exactly this cost. Being just poor (ahem) businessmen, they have asked the Abacus Calculator Makers for help. 

    You are given a description of the river network with costs of river segments and a sequence of integers x1,..., xk. For each xi, you should determine if there is a pair of cities (a, b) in the river network such that the cost of the trip between a and b is exactly xi. 
     

    Input

     

    The input consists of several instances. Each instance is described by (in the following order): 
    • A single line containing a single integer: the number of villages N (1 <= N <= 10 000). 
    • N lines describing the villages. The i-th of these lines (1 <= i <= N) describes the village with number i. It contains space separated integers d1, c1, d2, c2, , dki, cki, 0. The dj's are numbers of villages from which the rivers flow directly to the village i (with no other villages in between), each cj is the price of the journey between villages i and dj. Moreover, 2 <= dj <= N and 0 <= cj <= 1 000. Village 1 always corresponds to the mouth of the largest river, therefore no di can ever be equal to 1. 
    • M <= 100 lines describing the queries. The i-th of these lines corresponds to the i-th query and contains a single integer xi (1 <= xi <= 10 000 000). 
    • The instance is finished by a single line containing the number 0.

    The whole input is ended by a single line containing the number 0. 
     

    Output

     

    For each instance you should produce a sequence of M lines (where M is the number of queries in the particular instance). The i-th of these lines contains the word "AYE" if there exists a pair of cities in the river network which is connected by a path of cost xi, or the word "NAY" otherwise. 

    Output for each instance must be followed by a single line containing just the dot character. 
     

    Sample Input

     

    6
    2 5 3 7 4 1 0
    0
    5 2 6 3 0
    0
    0
    0
    1
    8
    13
    14
    0
    0

    Sample Output

     

    AYE
    AYE
    NAY
    AYE
    .

    题意:

      哇哇哇,POJ1741

      不会就去taobanzi啊

    #include <iostream>
    #include <cstdio>
    #include <cmath>
    #include <cstring>
    #include <vector>
    #include <algorithm>
    using namespace std;
    const int N = 1e4+20, M = 1e2+10, mod = 1e9+7, inf = 1e9+1000;
    typedef long long ll;
    
    int n,root,ans,siz[N],head[N],t,K,deep[N],allnode,vis[N],f[N],d[N];
    struct edg{int to,next,v;}e[N * 4];
    
    void add(int u,int v,int w) {e[t].to=v;e[t].v=w;e[t].next=head[u];head[u]=t++;}
    void init() {
        memset(head,0,sizeof(head));
        t = 1;
        ans = root = 0;
        memset(vis,0,sizeof(vis));
    }
    void getroot (int x,int fa) {
        siz[x] = 1; f[x] = 0;
        for(int i=head[x];i;i=e[i].next) {
            int to = e[i].to;
            if(to == fa || vis[to]) continue;
            getroot(to,x);
            siz[x] += siz[to];
            f[x] = max(f[x] , siz[to]);
        }
        f[x] = max(f[x] , allnode - siz[x]);
        if(f[x] < f[root]) root = x;
    }
    void getdeep(int x,int fa) {
        if(d[x] <= K)deep[++deep[0]] = d[x] ;
        for(int i=head[x];i;i=e[i].next) {
            int to = e[i].to;
            if(to == fa || vis[to]) continue;
            d[to] = d[x] + e[i].v;
            getdeep(to,x);
        }
    }
    int cal(int x,int now) {
        d[x]=now;deep[0]=0;
        getdeep(x,0);
        sort(deep+1,deep+deep[0]+1);
        int all = 0;
        for(int l=1,r=deep[0];l<r;) {
            if(deep[l] + deep[r] > K) r--;
            else if(deep[l] + deep[r] < K) l++;
            else {
                if(deep[l] == deep[r]) {all += (r-l+1)*(r-l)/2;break;}
                else {
                    int i = l , j = r;
                    while(deep[i]==deep[l]) i++;
                    while(deep[j]==deep[r]) j--;
                    int su = (i-l) * (r-j);
                    all += (su);
                    l=i;r=j;
                }
            }
        }
        return all;
    }
    void work(int x) {
        ans += cal(x,0);
        vis[x] = 1;
        for(int i=head[x];i;i=e[i].next) {
            int to = e[i].to;
            if(vis[to]) continue;
            ans -= cal(to,e[i].v);
            root=0;allnode=siz[to];
            getroot(to,root);
            work(root);
        }
    }
    int main()
    {
        while(scanf("%d",&n) && n) {
            init();
            for(int i=1;i<=n;i++) {
                int x,y;
                while(scanf("%d",&x) && x) {
                    scanf("%d",&y);
                    add(i,x,y);add(x,i,y);
                }
            }
            int x;
            while(scanf("%d",&x) && x) {
                K = x;
                ans = root = 0;
                memset(vis,0,sizeof(vis));
                allnode=n,f[0]=inf;
                getroot(1,-1);
                work(root);
                if(ans) puts("AYE");else puts("NAY");
            }
            puts(".");
        }
    }
  • 相关阅读:
    Struts2的%,#,$的区别,UI标签及其表单radio,checkbox,select回显数据(七)
    Struts2的控制标签库和数据标签库(六)
    Struts2从后端向前端传递数据和OGNL访问用户自定义静态方法(五)
    两个小例子登录和显示全部用户信息的模块(四)
    Struts2的ServletAPI的获取和各种类型的数据获取(三)
    Action的三种实现方式,struts.xml配置的详细解释及其简单执行过程(二)
    Struts2的 两个蝴蝶飞,你好 (一)
    虚拟机安装Centos7系统后优化操作
    Java进程故障排查(CPU资源占用高,接口响应超时,功能接口停滞等)
    zabbix企业微信报警实现
  • 原文地址:https://www.cnblogs.com/zxhl/p/5694419.html
Copyright © 2020-2023  润新知