• hdu 2594 Simpsons’ Hidden Talents KMP


    Simpsons’ Hidden Talents

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 4683    Accepted Submission(s): 1702


    Problem Description
    Homer: Marge, I just figured out a way to discover some of the talents we weren’t aware we had.
    Marge: Yeah, what is it?
    Homer: Take me for example. I want to find out if I have a talent in politics, OK?
    Marge: OK.
    Homer: So I take some politician’s name, say Clinton, and try to find the length of the longest prefix
    in Clinton’s name that is a suffix in my name. That’s how close I am to being a politician like Clinton
    Marge: Why on earth choose the longest prefix that is a suffix???
    Homer: Well, our talents are deeply hidden within ourselves, Marge.
    Marge: So how close are you?
    Homer: 0!
    Marge: I’m not surprised.
    Homer: But you know, you must have some real math talent hidden deep in you.
    Marge: How come?
    Homer: Riemann and Marjorie gives 3!!!
    Marge: Who the heck is Riemann?
    Homer: Never mind.
    Write a program that, when given strings s1 and s2, finds the longest prefix of s1 that is a suffix of s2.
     
    Input
    Input consists of two lines. The first line contains s1 and the second line contains s2. You may assume all letters are in lowercase.
     
    Output
    Output consists of a single line that contains the longest string that is a prefix of s1 and a suffix of s2, followed by the length of that prefix. If the longest such string is the empty string, then the output should be 0.
    The lengths of s1 and s2 will be at most 50000.
     
    Sample Input
    clinton homer riemann marjorie
     
    Sample Output
    0 rie 3
     
    Source
     
    题意:给定两个串S1和S2,你要找到S1的最长前缀,且这个前缀还要是S2的后缀.
    题解:KMP计算串S2的后缀能匹配S1的前缀是多长
    #include <cstdio>
    #include <string>
    #include <iostream>
    
    
    using namespace std;
    
    
    
    int maxl[50002],p[50002];
    
    int main()
    {string  a,b;
        while(cin>>b>>a)
        {
           
           b=" "+b;
           a=" "+a;
            int m=b.length();
            int n=a.length();
            n--;
            m--;
            memset(p,0,sizeof(p));
            memset(maxl,0,sizeof(maxl));
            p[0]=p[1]=0;
            int j=0;
            for(int i=2;i<=m;i++)
            {
                while(j>0&&b[j+1]!=b[i])j=p[j];
                if(b[j+1]==b[i])j++;
                p[i]=j;
            }
            j=0;
            for(int i=1;i<=n;i++)
            {
                while(j>0&&b[j+1]!=a[i])j=p[j];
                if(b[j+1]==a[i])j++;
                maxl[i]=j;
            }
            if(maxl[n]==0)cout<<0<<endl;
            else {
                for(int i=1;i<=maxl[n];i++)
                    cout<<b[i];
                cout<<" "<<maxl[n]<<endl;
            } getchar();
        }
        return 0;
    }
    代码
  • 相关阅读:
    2018-04-27 搭建Python官方文档翻译环境-汉化示例代码
    2018-04-21 搭建Python官方文档翻译环境
    2018-01-19 Xtext试用: 5步实现一个(中文)JVM语言
    2018-02-27 "Literate Programming"一书摘记之一
    2018-02-18 Antlr4实现简单语言之条件语句
    2018-02-17 中文代码示例[译]Scala中创建隐式函数
    2018-02-16 中文代码示例之冒泡算法, 后感
    C code example for strdup
    Hash table: why size should be prime?
    Hash table lengths and prime numbers
  • 原文地址:https://www.cnblogs.com/zxhl/p/4772067.html
Copyright © 2020-2023  润新知