• uva 129 Krypton Factor


     
    Description
    Download as PDF
     

    You have been employed by the organisers of a Super Krypton Factor Contest in which contestants have very high mental and physical abilities. In one section of the contest the contestants are tested on their ability to recall a sequence of characters which has been read to them by the Quiz Master. Many of the contestants are very good at recognising patterns. Therefore, in order to add some difficulty to this test, the organisers have decided that sequences containing certain types of repeated subsequences should not be used. However, they do not wish to remove all subsequences that are repeated, since in that case no single character could be repeated. This in itself would make the problem too easy for the contestants. Instead it is decided to eliminate all sequences containing an occurrence of two adjoining identical subsequences. Sequences containing such an occurrence will be called ``easy''. Other sequences will be called ``hard''.

    For example, the sequence ABACBCBAD is easy, since it contains an adjoining repetition of the subsequence CB. Other examples of easy sequences are:

    • BB
    • ABCDACABCAB
    • ABCDABCD

    Some examples of hard sequences are:

    • D
    • DC
    • ABDAB
    • CBABCBA

    Input and Output

    In order to provide the Quiz Master with a potentially unlimited source of questions you are asked to write a program that will read input lines that contain integers n and L (in that order), where n > 0 and L is in the range tex2html_wrap_inline39 , and for each input line prints out the nth hard sequence (composed of letters drawn from the first L letters in the alphabet), in increasing alphabetical order (alphabetical ordering here corresponds to the normal ordering encountered in a dictionary), followed (on the next line) by the length of that sequence. The first sequence in this ordering is A. You may assume that for given n and L there do exist at least n hard sequences.

    For example, with L = 3, the first 7 hard sequences are:

    A 
    AB 
    ABA 
    ABAC 
    ABACA 
    ABACAB 
    ABACABA

    As each sequence is potentially very long, split it into groups of four (4) characters separated by a space. If there are more than 16 such groups, please start a new line for the 17th group.

    Therefore, if the integers 7 and 3 appear on an input line, the output lines produced should be

    ABAC ABA
    7

    Input is terminated by a line containing two zeroes. Your program may assume a maximum sequence length of 80.

    Sample Input

    30 3
    0 0

    Sample Output

    ABAC ABCA CBAB CABA CABC ACBA CABA
    28

    难点在于是否存在相邻重复子串的判断,类似于八皇后问题,我们默认已求得的串都是困难的串,即不存在相邻重复子串。
    那么我们只需要考虑新加入的字母对于原串的影响,这样一层层地求,正好满足条件:已求得的串都是困难的串
    对于dfs,由于相同的字母是允许存在的,因此将其改为二维数组,记录字符位与字符值。
    #include <cstdio>
    #include <iostream>
    #include <cstring>
    using namespace std;
    int a[100];
    int book[100][30];
    int n,l;
    bool cm(int b[],int cur,int i)
    {
        for(int j=cur;j>=cur-i;j--)
        {
            if(b[j]!=b[j-i-1]) return false;
        }
        return true;
    }
    inline bool judge(int a[],int cur,int x)
    {
        int b[100];memcpy(b,a,cur*sizeof(int));
        b[cur]=x;
        for(int i=0;cur-(i+1)*2>=0;i++)
        {
            if(cm(b,cur,i)) return false;
        }
        return true;
    }
    inline void Print(int len)
    {
        int g=0;
        for(int i=1;i<len;i++)
        {
            printf("%c",a[i]-1+'A');
            if(i==64&&i!=len-1) puts("");
            else
            if(i%4==0&&i!=len-1)
            {
                printf(" ");
            }
        }
        printf("
    %d
    ",len-1);
    }
    int count;bool flag;
    void dfs(int cur,int pre)
    {
        if(flag) return;
        if(pre!=-1) count++;
        if(count==n&&!flag)
        {
            Print(cur);
            flag=true;
            return;
        }
        for(int i=1;i<=l;i++)
        {
           if(book[cur][i]) continue;
           if(cur==1)
           {
               a[cur]=i;
               book[cur][i]=1;
               dfs(cur+1,i);
               book[cur][i]=0;
           }
           else
           {
               if(pre==i) continue;
               if(judge(a,cur,i))
               {
                   a[cur]=i;
                   book[cur][i]=1;
                   dfs(cur+1,i);
                   book[cur][i]=0;
               }
           }
         }
    }
    int main()
    {
        while(~scanf("%d%d",&n,&l),n+l)
        {
            memset(book,0,sizeof(book));
            count=0;flag=false;
            dfs(1,-1);
        }
        return 0;
    }
  • 相关阅读:
    php 下设置cookie问题
    js 页面无滚动条添加滚轮事件
    Python中关于字符串的问题
    Python 字符串相加问题
    ajax 同步和异步
    重叠div鼠标经过事件
    Myeclipse中将项目上传到码云
    eclipse debug的时候提示debug Edit Source Lookup path
    阿里云+wordpress搭建个人博客网站
    centos7 安装mysql
  • 原文地址:https://www.cnblogs.com/zsyacm666666/p/5410367.html
Copyright © 2020-2023  润新知