• 第二章 I


    这是一道很坑爹的题,一定注意输入的两个数的大小,并且不能简单的交换,因为在最后的输出的时候还需要将原来的数按照原来的顺序和大小,这就是为什么还得开辟两个值得原因

    Description

    Problems in Computer Science are often classified as belonging to a certain class of problems (e.g., NP, Unsolvable, Recursive). In this problem you will be analyzing a property of an algorithm whose classification is not known for all possible inputs.
    Consider the following algorithm:
     
    
    		1. 		 input n
    
    
    
    		2. 		 print n
    
    
    
    		3. 		 if n = 1 then STOP
    
    
    
    		4. 		 		 if n is odd then   n <-- 3n+1
    
    
    
    		5. 		 		 else   n <-- n/2
    
    
    
    		6. 		 GOTO 2
    
    
    
    

    Given the input 22, the following sequence of numbers will be printed 22 11 34 17 52 26 13 40 20 10 5 16 8 4 2 1

    It is conjectured that the algorithm above will terminate (when a 1 is printed) for any integral input value. Despite the simplicity of the algorithm, it is unknown whether this conjecture is true. It has been verified, however, for all integers n such that 0 < n < 1,000,000 (and, in fact, for many more numbers than this.)

    Given an input n, it is possible to determine the number of numbers printed before the 1 is printed. For a given n this is called the cycle-length of n. In the example above, the cycle length of 22 is 16.

    For any two numbers i and j you are to determine the maximum cycle length over all numbers between i and j.


    Input

    The input will consist of a series of pairs of integers i and j, one pair of integers per line. All integers will be less than 10,000 and greater than 0.

    You should process all pairs of integers and for each pair determine the maximum cycle length over all integers between and including i and j.

    Output

    For each pair of input integers i and j you should output i, j, and the maximum cycle length for integers between and including i and j. These three numbers should be separated by at least one space with all three numbers on one line and with one line of output for each line of input. The integers i and j must appear in the output in the same order in which they appeared in the input and should be followed by the maximum cycle length (on the same line).

    Sample Input

    1 10
    100 200
    201 210
    900 1000

    Sample Output

    1 10 20
    100 200 125
    201 210 89
    900 1000 174

    #include<iostream>
    #include <cmath>
    using namespace std;
    int main ()
    {
     int m,n,w,j,i,max;
     while(cin>>m>>n)
     { 
      int x=m,y=n;
      if(m>n)
      { 
      int X=m;
               m=n;
         n=x;
      }
      max=-1;
      for(i=m;i<=n;i++)
      {
       j=i;
       w=0;
       while(j>1)
       {
        if(j%2!=0)
         j=3*j+1;
        else
         j=j/2;
        w++;
        //cout<<'*';
       }
         w++;
         if(max==-1)
          max=w;
         else
          if(max<w)
          max=w;
      }
     cout<<x<<' '<<y<<' '<<max<<endl;
     }
     return 0;
    }

  • 相关阅读:
    js实现对身份证校验
    zip解压缩
    zip压缩
    文件内容编解码
    文件的操作
    Mysql账号管理
    深度优先算法DFS
    Java常见知识问答
    Hibernate的单向OneToMany、单向ManyToOne
    Angularjs在线编辑器
  • 原文地址:https://www.cnblogs.com/zswbky/p/5432143.html
Copyright © 2020-2023  润新知