• 4.1.1 A


    Description

    A calendar is a system for measuring time, from hours and minutes, to months and days, and finally to years and centuries. The terms of hour, day, month, year and century are all units of time measurements of a calender system.
    According to the Gregorian calendar, which is the civil calendar in use today, years evenly divisible by 4 are leap years, with the exception of centurial years that are not evenly divisible by 400. Therefore, the years 1700, 1800, 1900 and 2100 are not leap years, but 1600, 2000, and 2400 are leap years.
    Given the number of days that have elapsed since January 1, 2000 A.D, your mission is to find the date and the day of the week.

    Input

    The input consists of lines each containing a positive integer, which is the number of days that have elapsed since January 1, 2000 A.D. The last line contains an integer −1, which should not be processed.
    You may assume that the resulting date won’t be after the year 9999.

    Output

    For each test case, output one line containing the date and the day of the week in the format of "YYYY-MM-DD DayOfWeek", where "DayOfWeek" must be one of "Sunday", "Monday", "Tuesday", "Wednesday", "Thursday", "Friday" and "Saturday".

    Sample Input

    1730
    1740
    1750
    1751
    -1

    Sample Output

    2004-09-26 Sunday
    2004-10-06 Wednesday
    2004-10-16 Saturday
    2004-10-17 Sunday

    这道题做的太坑爹了,竟然每一种情况都得考虑进来,所以出错率特别高,因此这样的方法是不好的,而应该建立一种比较好的范式

    #include <iostream>
    #include <cstdio>
    #include <cmath>
    using namespace std;
    int  wee=0,n,year=2000,month=1,day=1,x;
    char week[][10]={"Sunday", "Monday", "Tuesday", "Wednesday", "Thursday","Friday","Saturday"};
    bool isleap()
    {
      if((year%4==0&&year%100!=0)||year%400==0)
       return 1;
      return 0;
    }
    void whichday()
    {
     while(n>=31)
     {
      //cout<<;
        if(month==1||month==3||month==5||month==7||month==8||month==10||month==12)
           n=n-31;
        else
            if(month==4||month==6||month==9||month==11)
                n=n-30;
            else
                if(month==2&&x)
                  n=n-29;
                else
                    n=n-28;
              month++;

     }
     //cout<<month<<' '<<x<<' '<<n<<' ';
        if(n==30)
            if(month==1||month==3||month==5||month==7||month==8||month==10||month==12)
              day=31;
            else
              {
                  if(month==2&&x)
                    day=2;
                  else
                    if(month==2&&!x)
                    day=3;
                  else
                    day=1;
               month++;
              }
        else
            if(month==2&&(n==29||n==28))
                if((n==29&&x)||(n==28&&!x))
                  {
                  day=1;
                  month++;
                  }
                else
                  if(!x&&n==29)
                  {
                      month++;
                     day=2;
                     //cout<<day<<"MMMMMMMMMMMM";
                  }
                  else
                    day=n+1;
            else
                day=n+1;
            //cout<<n<<endl;
    }
    int main ()
    {
     cin>>n;
     while(n!=-1)
     {
      year=2000,month=1,day=1;
      int  wee=(n%7+6)%7;
      x=isleap();
      while(1)
      {
       x=isleap();
       if(n>=365)
       {
        if(x)
         if(n>=366)
         {
          n=n-366;
          year++;
         }
         else
          break;
        else
         if(n>=365)
         {
          n=n-365;
          year++;
         }
       }
       else
        break;
      }
            whichday();
      cout<<year<<'-';
      if(month<10)
       cout<<0;
      cout<<month<<'-';
      if(day<10)
       cout<<0;
      cout<<day<<' '<<week[wee]<<endl;
      cin>>n;
     }
     return 0;
    }

    简便,在找的同时查询时哪一天,思路简单!!!!!!

    #include <iostream>
    #include <string>       //string类型
    #include<cmath>
    #include <iomanip>
    #include <cstring>    //memset
    #include<algorithm>    //sort memset
    using namespace std;
    char week[][10]={"Sunday", "Monday", "Tuesday", "Wednesday", "Thursday","Friday","Saturday"};
    int Year(int year)
    {
      if((year%4==0&&year%100!=0)||year%400==0)
       return 366;
      return 365;
    }
    int Month(int month ,int year)
    {
    if(month==2)
    return Year(year)==366?29:28;
      if(month==1||month==3||month==5||month==7||month==8||month==10||month==12)
       return 31;
      else
       return 30;
    }
    int main()
    {
     int n;
     int year,month,day,wee;
     cin>>n;
     while(n>=0)
     {
      year=2000,month=1,day=1;
      wee=(n%7+6)%7;
            while(n)
      {
       if(n>=Year(year))
       {
        n=n-Year(year);
        year++;
       }
       else
        if(n>=Month(month,year))
        {
         n=n-Month(month,year);
         month++;
        }
        else
        {
         day=day+n;
         n=0;
        }
      }
           cout<<year<<'-'<<(month<10?"0":"")<<month<<'-'<<(day<10?"0":"")<<day<<' '<<week[wee]<<endl;//这样的输出格式必须是双引号!!!!!!
      cin>>n;
      
     }
     return 0;
    }

  • 相关阅读:
    Web API系列(三)统一异常处理
    Web API系列(二)接口安全和参数校验
    Web API系列(一)设计经验与总结
    文件并发(日志处理)--队列--Redis+Log4Net
    Jquery手机下拉刷新,下拉加载数据
    nginx 几个参数
    op cache config
    历史问题回顾
    第三方服务的使用
    nginx+php-fpm json_encode 到client pages 截断
  • 原文地址:https://www.cnblogs.com/zswbky/p/5432137.html
Copyright © 2020-2023  润新知