• Jungle Roads


    Description

     
    The Head Elder of the tropical island of Lagrishan has a problem. A burst of foreign aid money was spent on extra roads between villages some years ago. But the jungle overtakes roads relentlessly, so the large road network is too expensive to maintain. The Council of Elders must choose to stop maintaining some roads. The map above on the left shows all the roads in use now and the cost in aacms per month to maintain them. Of course there needs to be some way to get between all the villages on maintained roads, even if the route is not as short as before. The Chief Elder would like to tell the Council of Elders what would be the smallest amount they could spend in aacms per month to maintain roads that would connect all the villages. The villages are labeled A through I in the maps above. The map on the right shows the roads that could be maintained most cheaply, for 216 aacms per month. Your task is to write a program that will solve such problems.
    The input consists of one to 100 data sets, followed by a final line containing only 0. Each data set starts with a line containing only a number n, which is the number of villages, 1 < n < 27, and the villages are labeled with the first n letters of the alphabet, capitalized. Each data set is completed with n-1 lines that start with village labels in alphabetical order. There is no line for the last village. Each line for a village starts with the village label followed by a number, k, of roads from this village to villages with labels later in the alphabet. If k is greater than 0, the line continues with data for each of the k roads. The data for each road is the village label for the other end of the road followed by the monthly maintenance cost in aacms for the road. Maintenance costs will be positive integers less than 100. All data fields in the row are separated by single blanks. The road network will always allow travel between all the villages. The network will never have more than 75 roads. No village will have more than 15 roads going to other villages (before or after in the alphabet). In the sample input below, the first data set goes with the map above.
    The output is one integer per line for each data set: the minimum cost in aacms per month to maintain a road system that connect all the villages. Caution: A brute force solution that examines every possible set of roads will not finish within the one minute time limit.
     

    Input

    9 A 2 B 12 I 25 B 3 C 10 H 40 I 8 C 2 D 18 G 55 D 1 E 44 E 2 F 60 G 38 F 0 G 1 H 35 H 1 I 35 3 A 2 B 10 C 40 B 1 C 20 0
     

    Output

    216 30
     

    Sample Input

    9 A 2 B 12 I 25 B 3 C 10 H 40 I 8 C 2 D 18 G 55 D 1 E 44 E 2 F 60 G 38 F 0 G 1 H 35 H 1 I 35 3 A 2 B 10 C 40 B 1 C 20 0
     

    Sample Output

    216 30
     
     
     
    #include<stdio.h>
    #include<stdlib.h>
    #include<string.h>
    #include<algorithm>
    using namespace std;
    struct road
    {
    int start,end,len;
    };
    int father[30];
    int cha(int x)
    {
    if(x==father[x])
    return x;
    return cha(father[x]);
    }
    void bing(int x,int y)
    {
    father[cha(x)]=father[cha(y)];
    }
    bool cmp(road a,road b)
    {
    return a.len<b.len;
    }
    int main()
    {
    int n,m,i,j,count,road_sum;
    char place,place1; road data[5000];
    while(scanf("%d",&n)!=EOF,n)
    {
    road_sum=count=0;
    for( i=0; i<n-1; i++ )
    {
    getchar();
    scanf("%c%d",&place, &m);
    for(j=0;j<m;j++)
    {
    count++;
    data[count].start=place-64;
    getchar();
    scanf("%c%d",&place1,&data[count].len);
    data[count].end=place1-64;
    }
    }
    for(i=1;i<=n;i++)
    father[i]=i;
    sort(data+1,data+1+count,cmp);
    for(i=1;i<=count;i++)
    {
    if(cha(data[i].start)!=cha(data[i].end))
    {
    bing(data[i].start,data[i].end);
    road_sum+=data[i].len;
    }
    }
    printf("%d\n",road_sum);
    }
    }
  • 相关阅读:
    ElasticSearch已经配置好ik分词和mmseg分词(转)
    Java:Cookie实现记住用户名、密码
    (转)10大H5前端框架
    msysGit在GitHub代码托管
    mongodb 语句和SQL语句对应(SQL to Aggregation Mapping Chart)
    centos 7 安装redis
    mac下idea卡顿问题解决
    在linux系统中,使用tomcat的shutdown.sh脚本停止应用,但是进程还在的解决办法
    centOS 7.4 安装配置jdk1.8
    CentOS6 在线安装PostgreSQL10
  • 原文地址:https://www.cnblogs.com/zsj576637357/p/2405027.html
Copyright © 2020-2023  润新知