• An easy problem


    主要思想在与:B - 'A' + 1 = 2 ;   'a' - b - 1 = -2;

    Problem Description
    we define f(A) = 1, f(a) = -1, f(B) = 2, f(b) = -2, ... f(Z) = 26, f(z) = -26;
    Give you a letter x and a number y , you should output the result of y+f(x).
     
    Input
    On the first line, contains a number T.then T lines follow, each line is a case.each case contains a letter and a number.
     
    Output
    for each case, you should the result of y+f(x) on a line.
     
    Sample Input
    6 R 1 P 2 G 3 r 1 p 2 g 3
     
    Sample Output
    19 18 10 -17 -14 -4
     
     
     
    #include<stdio.h>
    #include<string.h>
    int main()
    {
        char ch[3];
         int a, n;
         scanf( "%d", &a );
         while( a-- )
         {
             int i = 0, sum = 0;
             scanf( "%s%d", ch, &n );
             if( ch[0] >= 'A' && ch[0] <= 'Z' )
                    i = ch[0] - 'A' + 1;
             else if( ch[0] >= 'a' && ch[0] <= 'z' )
                    i = 'a' - ch[0] - 1;
             sum = i + n ;
             printf( "%d\n", sum );
         }
         return 0;
    }
     
  • 相关阅读:
    4.18下午
    4.18上午
    2017.5.10-afternoon
    2017.5.9-afternoon
    2017.5.10-morning
    2017.5.9-morning
    2017.5.8-afternoon
    2017.5.8-morning
    2017.5.5-afternoon
    2017.5.5-morning
  • 原文地址:https://www.cnblogs.com/zsj576637357/p/2283493.html
Copyright © 2020-2023  润新知