Problem Description
Give you some integers, your task is to sort these number ascending (升序).
You should know how easy the problem is now!
Good luck!
Input
It is guarantied that all integers are in the range of 32-int.
Output
Sample Input
2 3 2 1 3 9 1 4 7 2 5 8 3 6 9
Sample Output
1 2 3 1 2 3 4 5 6 7 8 9
#include<stdio.h>
int main()
{
int t, n, num[100000];
int i, j, k, a;
scanf( "%d", &t );
for( i = 0 ; i < t; i++ )
{
scanf( "%d" , &n );
for( j = 0 ; j < n ; j++ )
scanf( "%d", &num[j] );
for( a = 0; a < (n-1); a++ )
for( j = 0; j < ((n-1)-a); j++ )
if( num[j] > num[j+1] )
{
k = num[j]; num[j] = num[j+1]; num[j+1] = k;
}
for( j = 0 ; j < n ; j++ )
printf( j == (n-1) ? "%d\n" : "%d ", num[j] );
}
getchar();getchar();
return 0;
}