• PAT 甲级 1130 Infix Expression


    https://pintia.cn/problem-sets/994805342720868352/problems/994805347921805312

    Given a syntax tree (binary), you are supposed to output the corresponding infix expression, with parentheses reflecting the precedences of the operators.

    Input Specification:

    Each input file contains one test case. For each case, the first line gives a positive integer N (≤ 20) which is the total number of nodes in the syntax tree. Then N lines follow, each gives the information of a node (the i-th line corresponds to the i-th node) in the format:

    data left_child right_child
    

    where data is a string of no more than 10 characters, left_child and right_child are the indices of this node's left and right children, respectively. The nodes are indexed from 1 to N. The NULL link is represented by −. The figures 1 and 2 correspond to the samples 1 and 2, respectively.

    infix1.JPGinfix2.JPG
    Figure 1 Figure 2

    Output Specification:

    For each case, print in a line the infix expression, with parentheses reflecting the precedences of the operators. Note that there must be no extra parentheses for the final expression, as is shown by the samples. There must be no space between any symbols.

    Sample Input 1:

    8
    * 8 7
    a -1 -1
    * 4 1
    + 2 5
    b -1 -1
    d -1 -1
    - -1 6
    c -1 -1
    

    Sample Output 1:

    (a+b)*(c*(-d))
    

    Sample Input 2:

    8
    2.35 -1 -1
    * 6 1
    - -1 4
    % 7 8
    + 2 3
    a -1 -1
    str -1 -1
    871 -1 -1
    

    Sample Output 2:

    (a*2.35)+(-(str%871))

    代码:

    #include <bits/stdc++.h>
    using namespace std;
    
    int N;
    int vis[30];
    
    struct Node{
        string val;
        int L, R;
    }node[30];
    
    string dfs(int st) {
        if(node[st].L == -1 && node[st].R == -1) return node[st].val;
        if(node[st].L == -1 && node[st].R != -1) return "(" + node[st].val + dfs(node[st].R) + ")";
        if(node[st].L != -1 && node[st].R != -1) return "(" + dfs(node[st].L) + node[st].val + dfs(node[st].R) + ")";
    }
    
    int main() {
        scanf("%d", &N);
        for(int i = 1; i <= N; i ++) {
            cin >> node[i].val >> node[i].L >> node[i].R;
            if(node[i].L != -1) vis[node[i].L] = 1;
            if(node[i].R != -1) vis[node[i].R] = 1;
        }
    
        int root = 1;
        while(vis[root] == 1) root ++;
        string ans = dfs(root);
        if(ans[0] == '(') ans = ans.substr(1, ans.size() - 2);
        cout << ans;
        return 0;
    }
    

      dfs 递归 最后去掉最外面的括号

    可能最近是自闭 girl 了 希望有好运气叭

  • 相关阅读:
    根据系统的pid查询sql语句
    DORADO实现动态拼装查询条件
    一个Spring的配置管理接口
    MS SQL Server Management Studio连接到SQL Server命名实例的方法
    WSDL学习笔记
    显示MyBatis/Ibatis的SQL语句
    测试代码显示
    C#中一个项目中无法引用另外一个项目中的类的问题
    Learn How To Use LogMiner(Practice)
    WIN2003 IIS6 FastCGI php5.33配置重点
  • 原文地址:https://www.cnblogs.com/zlrrrr/p/10417606.html
Copyright © 2020-2023  润新知