• PAT Advance 1014


    题目:

    1014. Waiting in Line (30)

    时间限制
    400 ms
    内存限制
    32000 kB
    代码长度限制
    16000 B
    判题程序
    Standard
    作者
    CHEN, Yue

    Suppose a bank has N windows open for service. There is a yellow line in front of the windows which devides the waiting area into two parts. The rules for the customers to wait in line are:

    • The space inside the yellow line in front of each window is enough to contain a line with M customers. Hence when all the N lines are full, all the customers after (and including) the (NM+1)st one will have to wait in a line behind the yellow line.
    • Each customer will choose the shortest line to wait in when crossing the yellow line. If there are two or more lines with the same length, the customer will always choose the window with the smallest number.
    • Customer[i] will take T[i] minutes to have his/her transaction processed.
    • The first N customers are assumed to be served at 8:00am.

    Now given the processing time of each customer, you are supposed to tell the exact time at which a customer has his/her business done.

    For example, suppose that a bank has 2 windows and each window may have 2 custmers waiting inside the yellow line. There are 5 customers waiting with transactions taking 1, 2, 6, 4 and 3 minutes, respectively. At 08:00 in the morning, customer1 is served at window1 while customer2 is served at window2. Customer3 will wait in front of window1 and customer4 will wait in front of window2. Customer5 will wait behind the yellow line.

    At 08:01, customer1 is done and customer5 enters the line in front of window1 since that line seems shorter now. Customer2 will leave at 08:02, customer4 at 08:06, customer3 at 08:07, and finally customer5 at 08:10.

    Input

    Each input file contains one test case. Each case starts with a line containing 4 positive integers: N (<=20, number of windows), M (<=10, the maximum capacity of each line inside the yellow line), K (<=1000, number of customers), and Q (<=1000, number of customer queries).

    The next line contains K positive integers, which are the processing time of the K customers.

    The last line contains Q positive integers, which represent the customers who are asking about the time they can have their transactions done. The customers are numbered from 1 to K.

    Output

    For each of the Q customers, print in one line the time at which his/her transaction is finished, in the format HH:MM where HH is in [08, 17] and MM is in [00, 59]. Note that since the bank is closed everyday after 17:00, for those customers who cannot be served before 17:00, you must output "Sorry" instead.

    Sample Input
    2 2 7 5
    1 2 6 4 3 534 2
    3 4 5 6 7
    
    Sample Output
    08:07
    08:06
    08:10
    17:00
    Sorry

    注意点:

    测试点5:容易超时,是因为测试案例k值很大

    测试点2和4:开始服务时间不能超过17:00,如以下测试用例

    Sample Input

    2 2 5 5
    1 1 540 540 1
    1 2 3 4 5

    Sample Output

    08:01

    08:01

    17:01

    17:01

    Sorry

    程序:

    #include<iostream>

    using namespace std;

    #define MAX 1000

    int n,m,k,q;
    int t[MAX];
    int num[MAX][MAX];
    int done[MAX][MAX];

    void intToString(int a){
    int h = 8;
    int m = 0;
    h += a/60;
    m += a%60;
    cout<<h/10<<h%10<<":"<<m/10<<m%10<<endl;
    }

    int findMin(int a[]){
    int i,min = 0;
    for(i=1;i<n;i++)
    if(a[min] > a[i])
    min = i;
    return min;
    }

    void initNum(){
    int i,j;
    for(i=0;i<k;i++)
    for(j=0;j<k;j++)
    num[i][j] = k+1;
    }

    int main(){
    cin>>n>>m>>k>>q;
    int i,j,l;
    for(i=0;i<k;i++){
    cin>>t[i];
    }
    initNum();
    int window[MAX];
    int hnum[MAX];
    for(i=0;i<n;i++)
    if(i<k){
    done[0][i] = t[i];
    num[0][i] = i;
    window[i] = t[i];
    hnum[i] = 0;
    }
    for(i=1;i<m;i++)
    for(j=0;j<n;j++)
    if((i*n+j)<k){
    num[i][j] = i*n + j;
    done[i][j] = done[i-1][j] + t[num[i][j]];
    }
    int temp;
    for(i=n*m;i<k;i++){
    temp = findMin(window);
    hnum[temp]++;
    window[temp] = done[hnum[temp]][temp];
    num[m+hnum[temp]-1][temp] = i;
    done[m+hnum[temp]-1][temp] = done[m+hnum[temp]-2][temp] + t[i];
    }
    for(i=0;i<q;i++){
    cin>>temp;
    if(temp<=m*n){
    if(temp<=n)
    intToString(done[(temp-1)/n][(temp-1)%n]);
    else{
    if(done[(temp-1)/n-1][(temp-1)%n] >= 540)
    cout<<"Sorry"<<endl;
    else
    intToString(done[(temp-1)/n][(temp-1)%n]);
    }
    }else{
    for(j=m;j<k;j++)
    for(l=0;l<n;l++)
    if(num[j][l] == (temp-1))
    if(j>=1&&done[j-1][l]>=540)
    cout<<"Sorry"<<endl;
    else
    intToString(done[j][l]);
    }
    }
    return 0;
    }

  • 相关阅读:
    MetaWeblog API
    序列化Hashtable
    贴几个CodeDOM的链接
    Summing it all up: 35 blog entries in 2 days from the BCL Team [Kit George] --from BCLTeam's Weblog
    上海在下尘土
    PSP升级速度令然惊喜!(update:2007.10.13)
    Linkin Park林肯公园上海演唱会(2007年11月18日)
    STARCRAFT2 / 星际争霸2
    Enterprise Library 3.0 April 2007
    《The Devil Wears Prada / 穿布拉达的女王》很有意思.
  • 原文地址:https://www.cnblogs.com/zjuzcj/p/3571731.html
Copyright © 2020-2023  润新知