• Climbing Worm- hdu-1049


    Climbing Worm

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 10022    Accepted Submission(s): 6603

    Problem Description

    An inch worm is at the bottom of a well n inches deep. It has enough energy to climb u inches every minute, but then has to rest a minute before climbing again. During the rest, it slips down d inches. The process of climbing and resting then repeats. How long before the worm climbs out of the well? We'll always count a portion of a minute as a whole minute and if the worm just reaches the top of the well at the end of its climbing, we'll assume the worm makes it out.

     

     

    Input

    There will be multiple problem instances. Each line will contain 3 positive integers n, u and d. These give the values mentioned in the paragraph above. Furthermore, you may assume d < u and n < 100. A value of n = 0 indicates end of output.

     

     

    Output

    Each input instance should generate a single integer on a line, indicating the number of minutes it takes for the worm to climb out of the well.

     

     

    Sample Input

    10 2 1

    20 3 1

    0 0 0

     

     

    Sample Output

    17

    19

    题目的大概意思:就是井深n米,每分钟向上爬u米;每爬一分钟就休息一分钟,休息的时候向下滑落d米;输出:一共需要多少分钟爬出井外。

    #include<stdio.h>

    int main()

    {

        int a,b,c,i,t,k;

        while(scanf("%d%d%d",&a,&b,&c)&&(a!=0&&b!=0&&c!=0))

    {

          i=1;k=b;t=0;

          while(1)

          {

           if(k>=a)

           {printf("%d ",i);break;}

           k=k-c+b;

           i=i+2;//要求的答案是总共所用的时间(向上爬的时间加上休息的时间 ) 所以是 i+2;而不是 i+1

          }

        }

        return 0;

    }

  • 相关阅读:
    项目中见过最好的创建树的过程
    验证Math.random()函数产生的是均匀分布的数值
    一道LINQ题,可以瞅一眼
    EntityFramework5的性能到底提高在哪里了?
    如何很好的使用Linq的Distinct方法
    EntityFramework开发三种工作流简介
    实现自动抛弃当前数据库上下文的模块。支持各种ORM框架并存
    SPS中WebPart加缓存
    交流与设计,项目管理中必备的!
    redmine 安装roadmap 插件
  • 原文地址:https://www.cnblogs.com/zhouhongweihpu/p/3218028.html
Copyright © 2020-2023  润新知