• Kattis


    Aaah!

    /problems/aaah/file/statement/en/img-0001.jpg
    Photo by Unknown

    Jon Marius shouted too much at the recent Justin Bieber concert, and now needs to go to the doctor because of his sore throat. The doctor’s instructions are to say “aaah”. Unfortunately, the doctors sometimes need Jon Marius to say “aaah” for a while, which Jon Marius has never been good at. Each doctor requires a certain level of “aah” – some require “aaaaaah”, while others can actually diagnose his throat with just an “h”. (They often diagnose wrongly, but that is beyond the scope of this problem.) Since Jon Marius does not want to go to a doctor and have his time wasted, he wants to compare how long he manages to hold the “aaah” with the doctor’s requirements. (After all, who wants to be all like “aaah” when the doctor wants you to go “aaaaaah”?)

    Each day Jon Marius calls up a different doctor and asks them how long his “aaah” has to be. Find out if Jon Marius would waste his time going to the given doctor.

    Input

    The input consists of two lines. The first line is the “aaah” Jon Marius is able to say that day. The second line is the “aah” the doctor wants to hear. Only lowercase ’a’ and ’h’ will be used in the input, and each line will contain between 00 and 999999 ’a’s, inclusive, followed by a single ’h’.

    Output

    Output “go” if Jon Marius can go to that doctor, and output “no” otherwise.

    Sample Input 1Sample Output 1
    aaah
    aaaaah
    
    no
    
    Sample Input 2Sample Output 2
    aaah
    ah
    
    go

    题意

    判断那人要不要去看医生,如果前面的字符串比后面的短,证明不用,否则就用

    思路

    比较字符串长度

    代码

    #include<bits/stdc++.h>
    using namespace std;
    char a1[1005],a2[1005];
    int main() {
        while (~scanf("%s %s", a1,a2))
        {
            puts(strlen(a1) < strlen(a2) ? "no" : "go");
        }
        return 0;
    }
  • 相关阅读:
    前端乔与前端开发的恋爱日记【2021年终总结】
    mysql平常总结
    leader故障处理细节(当leader发生故障的时候)
    kafka文件存储机制
    Kafka学习之Kafka选举机制简述
    kafka副本总结
    生产经验——Leader Partition 负载平衡
    vuecli
    vue
    2.17 第一次运行 成功 vs code
  • 原文地址:https://www.cnblogs.com/zhien-aa/p/6285903.html
Copyright © 2020-2023  润新知