• poj Drainage Ditches(最大流入门)


    Drainage Ditches
    Time Limit: 1000MS   Memory Limit: 10000K
    Total Submissions: 85250   Accepted: 33164

    Description

    Every time it rains on Farmer John's fields, a pond forms over Bessie's favorite clover patch. This means that the clover is covered by water for awhile and takes quite a long time to regrow. Thus, Farmer John has built a set of drainage ditches so that Bessie's clover patch is never covered in water. Instead, the water is drained to a nearby stream. Being an ace engineer, Farmer John has also installed regulators at the beginning of each ditch, so he can control at what rate water flows into that ditch. 
    Farmer John knows not only how many gallons of water each ditch can transport per minute but also the exact layout of the ditches, which feed out of the pond and into each other and stream in a potentially complex network. 
    Given all this information, determine the maximum rate at which water can be transported out of the pond and into the stream. For any given ditch, water flows in only one direction, but there might be a way that water can flow in a circle. 

    Input

    The input includes several cases. For each case, the first line contains two space-separated integers, N (0 <= N <= 200) and M (2 <= M <= 200). N is the number of ditches that Farmer John has dug. M is the number of intersections points for those ditches. Intersection 1 is the pond. Intersection point M is the stream. Each of the following N lines contains three integers, Si, Ei, and Ci. Si and Ei (1 <= Si, Ei <= M) designate the intersections between which this ditch flows. Water will flow through this ditch from Si to Ei. Ci (0 <= Ci <= 10,000,000) is the maximum rate at which water will flow through the ditch.

    Output

    For each case, output a single integer, the maximum rate at which water may emptied from the pond.

    Sample Input

    5 4
    1 2 40
    1 4 20
    2 4 20
    2 3 30
    3 4 10
    

    Sample Output

    50

    Source

    题意:最大流问题
    代码:
    #include<stdio.h>
    #include<string.h>
    #include<iostream>
    #include<algorithm>
    #include<vector>
    #define MAX 205
    #define INF 0x3f3f3f3f
    #define pb push_back
    using namespace std;
    struct edge{
    int to,cap,rev;
    edge(){}
    edge(int to,int cap,int rev):to(to),cap(cap),rev(rev){}
    };
    vector<edge>G[MAX];
    bool used[MAX];
    void add_edge(int from,int to,int cap)
    {
        G[from].pb(edge(to,cap,G[to].size()));
        G[to].pb(edge(from,0,G[from].size()-1));
    }
    int dfs(int v,int t,int f)
    {
        if(v==t)return f;
        used[v]=true;
        for(int i=0;i<G[v].size();i++)
        {
            edge &e=G[v][i];
            //cout<<e.to<<endl;
            if(!used[e.to]&&e.cap>0)
            {
                int d=dfs(e.to,t,min(f,e.cap));
                if(d>0)
                {
                    e.cap-=d;
                    G[e.to][e.rev].cap+=d;
                    return d;
                }
            }
        }
        return 0;
    }
    int max_flow(int s,int t)
    {
        int flow=0;
        for(;;)
        {
            memset(used,0,sizeof(used));
            int f=dfs(s,t,INF);
            if(f==0)
                return flow;
            flow+=f;
        }
    }
    int main()
    {
        int n,m;
           while(cin>>n>>m){
               for(int i=0;i<n;i++)
                G[i].clear();
            for(int i=0;i<n;i++)
            {
                int u,v,cap;
                cin>>u>>v>>cap;
                add_edge(u,v,cap);
            }
            cout<<max_flow(1,m)<<endl;
        }
    }
    Ford_Fulkerson
    #include<string.h>
    #include<iostream>
    #include<algorithm>
    #include<vector>
    #include<queue>
    using namespace std;
    const int maxn = 205;
    const int INF = 0x3f3f3f3f;
    
    struct Edge
    {
        int from,to,cap,flow;
        Edge(){}
        Edge(int from,int to,int cap,int flow):from(from),to(to),cap(cap),flow(flow){}
    };
    
    struct Dinic
    {
        int n,m,s,t;            //结点数,边数(包括反向弧),源点与汇点编号
        vector<Edge> edges;     //边表 edges[e]和edges[e^1]互为反向弧
        vector<int> G[maxn];    //邻接表,G[i][j]表示结点i的第j条边在e数组中的序号
        bool vis[maxn];         //BFS使用,标记一个节点是否被遍历过
        int d[maxn];            //d[i]表从起点s到i点的距离(层次)
        int cur[maxn];          //cur[i]表当前正访问i节点的第cur[i]条弧
    
        void init(int n,int s,int t)
        {
            this->n=n,this->s=s,this->t=t;
            for(int i=0;i<=n;i++) G[i].clear();
            edges.clear();
        }
    
        void AddEdge(int from,int to,int cap)
        {
            edges.push_back( Edge(from,to,cap,0) );
            edges.push_back( Edge(to,from,0,0) );
            m = edges.size();
            G[from].push_back(m-2);
            G[to].push_back(m-1);
        }
    
        bool BFS()
        {
            memset(vis,0,sizeof(vis));
            queue<int> Q;//用来保存节点编号的
            Q.push(s);
            d[s]=0;
            vis[s]=true;
            while(!Q.empty())
            {
                int x=Q.front(); Q.pop();
                for(int i=0; i<G[x].size(); i++)
                {
                    Edge& e=edges[G[x][i]];
                    if(!vis[e.to] && e.cap>e.flow)
                    {
                        vis[e.to]=true;
                        d[e.to] = d[x]+1;
                        Q.push(e.to);
                    }
                }
            }
            return vis[t];
        }
    
        //a表示从s到x目前为止所有弧的最小残量
        //flow表示从x到t的最小残量
        int DFS(int x,int a)
        {
            if(x==t || a==0)return a;
            int flow=0,f;//flow用来记录从x到t的最小残量
            for(int& i=cur[x]; i<G[x].size(); i++)
            {
                Edge& e=edges[G[x][i]];
                if(d[x]+1==d[e.to] && (f=DFS( e.to,min(a,e.cap-e.flow) ) )>0 )
                {
                    e.flow +=f;
                    edges[G[x][i]^1].flow -=f;
                    flow += f;
                    a -= f;
                    if(a==0) break;
                }
            }
            if(!flow) d[x] = -1;///炸点优化
            return flow;
        }
    
        int Maxflow()
        {
            int flow=0;
            while(BFS())
            {
                memset(cur,0,sizeof(cur));
                flow += DFS(s,INF);
            }
            return flow;
        }
    }Di;
    int main()
    {
        int n,m;
    
        while(cin>>n>>m){
            Di.init(n,1,m);
        for(int i=0;i<n;i++)
        {
            int v,u,rap;
            cin>>u>>v>>rap;
            Di.AddEdge(u,v,rap);
        }
         cout<<Di.Maxflow()<<endl;
       }
    }
    Dinic
  • 相关阅读:
    2021年中国DevOps现状调查报告发布!
    带你看清梦饷集团如何成为上海在线新经济四小龙
    AI论文解读丨融合视觉、语义、关系多模态信息的文档版面分析架构VSR
    云图说 | 华为云医疗智能体,智联大健康,AI药物研发
    带你走进“华为链”
    初学者入门知识图谱必看的能力:推理
    带你探索CPU调度的奥秘
    鸿蒙轻内核定时器Swtmr:不受硬件和数量限制,满足用户需求
    FLINK基础(137):DS流与表转换(3) Handling of (Insert-Only) Streams(2)fromDataStream(FLINK1.13以上)
    FLINK基础(136):DS流与表转换(2) Handling of (Insert-Only) Streams(1)简介(FLINK1.13以上)
  • 原文地址:https://www.cnblogs.com/zhgyki/p/9537240.html
Copyright © 2020-2023  润新知