• hdu 1087 Super Jumping! Jumping! Jumping!(动态规划DP)


    题目链接http://acm.hdu.edu.cn/showproblem.php?pid=1087

    Super Jumping! Jumping! Jumping!

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 24452    Accepted Submission(s): 10786


    Problem Description
    Nowadays, a kind of chess game called “Super Jumping! Jumping! Jumping!” is very popular in HDU. Maybe you are a good boy, and know little about this game, so I introduce it to you now.



    The game can be played by two or more than two players. It consists of a chessboard(棋盘)and some chessmen(棋子), and all chessmen are marked by a positive integer or “start” or “end”. The player starts from start-point and must jumps into end-point finally. In the course of jumping, the player will visit the chessmen in the path, but everyone must jumps from one chessman to another absolutely bigger (you can assume start-point is a minimum and end-point is a maximum.). And all players cannot go backwards. One jumping can go from a chessman to next, also can go across many chessmen, and even you can straightly get to end-point from start-point. Of course you get zero point in this situation. A player is a winner if and only if he can get a bigger score according to his jumping solution. Note that your score comes from the sum of value on the chessmen in you jumping path.
    Your task is to output the maximum value according to the given chessmen list.
     

     

    Input
    Input contains multiple test cases. Each test case is described in a line as follow:
    N value_1 value_2 …value_N 
    It is guarantied that N is not more than 1000 and all value_i are in the range of 32-int.
    A test case starting with 0 terminates the input and this test case is not to be processed.
     

     

    Output
    For each case, print the maximum according to rules, and one line one case.
     

     

    Sample Input
    3 1 3 2
    4 1 2 3 4
    4 3 3 2 1
    0
     
    Sample Output
    4
    10
    3
    题意:求最大递增子序列的和
    题解:dp[i]表示以a[i]结尾的最大递增序列的最大值,那么dp[j]=max(dp[j],dp[i]+a[j])  (a[i]<a[j])
    代码:
    #include<stdio.h>
    #include<string.h>
    #include<algorithm>
    #include<iostream>
    using namespace std;
    #define rep(i,a,n) for (int i=a;i<n;i++)
    #define per(i,a,n) for (int i=n-1;i>=a;i--)
    #define pb push_back
    #define mp make_pair
    #define all(x) (x).begin(),(x).end()
    #define fi first
    #define se second
    #define SZ(x) ((int)(x).size())
    typedef long long ll;
    typedef pair<int,int> PII;
    const ll mod=1000000007;
    ll gcd(ll a,ll b) { return b?gcd(b,a%b):a;}
    // head
    #define MAX 1005
    int dp[MAX];
    int a[MAX];
    int n;
    int main()
    {
        ios_base::sync_with_stdio(0);
        cin.tie(0);
        while(cin>>n)
        {
            if(n==0)break;
            memset(dp,0,sizeof(dp));
            memset(a,0,sizeof(a));
            for(int i=1;i<=n;i++)
            {
                cin>>a[i];
                dp[i]=a[i];
            }
            for(int i=1;i<=n;i++)
            {
                for(int j=i+1;j<=n;j++)
                {
                if(a[j]>a[i])
                    dp[j]=max(dp[i]+a[j],dp[j]);
                //else dp[j]=max(dp[j],)
             }
            }
            int minn=0;
            for(int i=1;i<=n;i++)
                minn=max(minn,dp[i]);
            cout<<minn<<endl;
        }
    }

     也可以这么写:

    #include<stdio.h>
    #include<string.h>
    #include<algorithm>
    #include<iostream>
    using namespace std;
    #define rep(i,a,n) for (int i=a;i<n;i++)
    #define per(i,a,n) for (int i=n-1;i>=a;i--)
    #define pb push_back
    #define mp make_pair
    #define all(x) (x).begin(),(x).end()
    #define fi first
    #define se second
    #define SZ(x) ((int)(x).size())
    typedef long long ll;
    typedef pair<int,int> PII;
    const ll mod=1000000007;
    ll gcd(ll a,ll b) { return b?gcd(b,a%b):a;}
    // head
    #define MAX 1005
    int dp[MAX];
    int a[MAX];
    int n;
    int main()
    {
        ios_base::sync_with_stdio(0);
        cin.tie(0);
        while(cin>>n)
        {
            if(n==0)break;
            memset(dp,0,sizeof(dp));
            memset(a,0,sizeof(a));
            for(int i=1;i<=n;i++)
            {
                cin>>a[i];
                dp[i]=a[i];
            }
            for(int i=1;i<=n;i++)
            {
                for(int j=1;j<i;j++)
                {
                if(a[j]<a[i])
                    dp[i]=max(dp[j]+a[i],dp[i]);
                //else dp[j]=max(dp[j],)
             }
            }
            int minn=0;
            for(int i=1;i<=n;i++)
                minn=max(minn,dp[i]);
            cout<<minn<<endl;
        }
    }

    这个问题与LIS思维是一样的,只不过最长上升子序列计算的是长度,两者的递推式也是类似的

    LIS:  dp[i]=max{dp[i],dp[j]+1}(j<i&&a[j]<a[i])

    该题:dp[i]=max{dp[i],dp[j]+a[i]}(j<i&&a[j]<a[i])

  • 相关阅读:
    下载视频
    009 逻辑 + MFC CString
    008 浅拷贝与深拷贝
    007 operator
    006 this指针原理
    005 逻辑 + STL list
    004 list::sort
    003 逻辑 + mfc CList
    001 C++历史和思想
    并查集模板
  • 原文地址:https://www.cnblogs.com/zhgyki/p/9493518.html
Copyright © 2020-2023  润新知