• PAT-A 1078. Hashing


    1078. Hashing

    The task of this problem is simple: insert a sequence of distinct positive integers into a hash table, and output the positions of the input numbers. The hash function is defined to be "H(key) = key % TSize" where TSize is the maximum size of the hash table. Quadratic probing (with positive increments only) is used to solve the collisions.

    Note that the table size is better to be prime. If the maximum size given by the user is not prime, you must re-define the table size to be the smallest prime number which is larger than the size given by the user.

    Input Specification:

    Each input file contains one test case. For each case, the first line contains two positive numbers: MSize (<=104) and N (<=MSize) which are the user-defined table size and the number of input numbers, respectively. Then N distinct positive integers are given in the next line. All the numbers in a line are separated by a space.

    Output Specification:

    For each test case, print the corresponding positions (index starts from 0) of the input numbers in one line. All the numbers in a line are separated by a space, and there must be no extra space at the end of the line. In case it is impossible to insert the number, print "-" instead.

    Sample Input:

    4 4
    10 6 4 15
    

    Sample Output:

    0 1 4 -
    

    哈希表的二次探测公式
    $$hash(key)=(key+i^2)%Tsize,i=0,1,2...$$

    程序代码:

    #include<iostream>
    #include<vector>
    #include<cmath>
    using namespace std;
    int NextPrime(int a);
    int main()
    {
    	int Tsize,N,tmp;
    	vector<int> num;
    	vector<int>position;
    	cin>>Tsize>>N;
    	Tsize = NextPrime(Tsize);
    	int p;
    	for(int i=0;i<N;i++)
    	{
    		cin>>tmp;
    		num.push_back(tmp);
    	}
    	for(int i=0;i<Tsize;i++)
    		position.push_back(-1);
    	
    	for(int i=0;i<N;i++)
    	{
    		tmp = num[i];
    		for(int j=0;;j++)
    		{
    			p = (tmp+(int)pow(j,2))%Tsize;
    			
    			if(position[p]==-1)
    			{
    				position[p]=1;
    				cout<<p;
    				break;
    			}
    			if(p==tmp%Tsize&&j!=0)
    			{
    				cout<<'-';
    				break;
    			}
    		}
    		if(i<N-1)
    			cout<<' ';
    	}
    }
    int NextPrime(int a)//求大于等于a的第一个素数
    {
    	int i;
    	if(a<2)
    		return 2;
    	for(i=2;i<=sqrt(a);i++)
    	{
    		if(a%i==0)
    		{
    			a++;
    			i=1;
    		}
    	}
    	return a;
    }
    
    
  • 相关阅读:
    Js内存泄漏的几种情况
    简单工厂模式
    单例模式
    设计模式简介
    百度地图api-动态添加覆盖物
    ArcGIS发布地图服务后直接调用查看方法
    NetCDF 共享软件 中文
    Oracle服务器重命名
    NETCDF入门
    Oracle11gExpress和PL/SQL Developer安装
  • 原文地址:https://www.cnblogs.com/zhengkang/p/5770587.html
Copyright © 2020-2023  润新知