• bzoj1655 [Usaco2006 Jan] Dollar Dayz 奶牛商店


    Description

    Farmer John goes to Dollar Days at The Cow Store and discovers an unlimited number of tools on sale. During his first visit, the tools are selling variously for $1, $2, and $3. Farmer John has exactly $5 to spend. He can buy 5 tools at $1 each or 1 tool at $3 and an additional 1 tool at $2. Of course, there are other combinations for a total of 5 different ways FJ can spend all his money on tools. Here they are: 1 @ US$3 + 1 @ US$2 1 @ US$3 + 2 @ US$1 1 @ US$2 + 3 @ US$1 2 @ US$2 + 1 @ US$1 5 @ US$1 Write a program than will compute the number of ways FJ can spend N dollars (1 <= N <= 1000) at The Cow Store for tools on sale with a cost of $1..$K (1 <= K <= 100).

        约翰到奶牛商场里买工具.商场里有K(1≤K≤100).种工具,价格分别为1,2,…,K美元.约翰手里有N(1≤N≤1000)美元,必须花完.那他有多少种购买的组合呢?

    Input

    A single line with two space-separated integers: N and K.

        仅一行,输入N,K.

    Output

    A single line with a single integer that is the number of unique ways FJ can spend his money.

        不同的购买组合数.

    Sample Input

    5 3

    Sample Output

    5

    就是很水的完全背包

    f[j]=f[j]+f[j - i]

    一开始以为是部分背包,然后样例都过不了……

    改成完全背包又wa了……

    结果发现USACO数据里有20多位的答案……

    没办法改高精度吧……

    #include<cstdio>
    struct bignum{
    	int len;
    	int a[100];
    }f[1001];
    int n,k;
    inline int max(int a,int b)
    {return a>b?a:b;}
    inline int min(int a,int b)
    {return a<b?a:b;}
    inline void add(int i,int j,bignum &k)
    {
    	bignum ans;
    	ans.len=max(f[j-i].len,f[j].len);
    	for (int l=1;l<=ans.len;l++)
    	  ans.a[l]=f[j-i].a[l]+f[j].a[l];
    	ans.a[ans.len+1]=0;
    	for (int l=1;l<=ans.len;l++)
    	  {
    	  	ans.a[l+1]+=ans.a[l]/10;
    	  	ans.a[l]%=10;
    	  }
    	if (ans.a[ans.len+1])ans.len++;
    	k.len=ans.len;
    	for (int i=1;i<=ans.len;i++)
    	  k.a[i]=ans.a[i];
    }
    int main()
    {
    	scanf("%d%d",&n,&k);
    	f[0].len=f[0].a[1]=1;
    	for (int i=1;i<=min(n,k);i++)
    	  for (int j=i;j<=n;j++)
    	    add(i,j,f[j]);
    	for (int i=f[n].len;i>=1;i--)
    	  printf("%d",f[n].a[i]);
    }


    ——by zhber,转载请注明来源
  • 相关阅读:
    前后端分离的坑
    appscan 对于csrf漏洞扫描的坑
    appscan执行过程
    app scan状态码的坑
    linux修改jdk版本
    软件测试之性能测试
    jmeter 从文件中读取内容 CSV数据文件设置(CSV Data Set Config)
    robotframework基本操作
    robotframework生成随机数
    RobotFramework获取table的行数
  • 原文地址:https://www.cnblogs.com/zhber/p/4036034.html
Copyright © 2020-2023  润新知