• PAT-1134 Vertex Cover (图的建立 + set容器)


    A vertex cover of a graph is a set of vertices such that each edge of the graph is incident to at least one vertex of the set. Now given a graph with several vertex sets, you are supposed to tell if each of them is a vertex cover or not.

    Input Specification:
    Each input file contains one test case. For each case, the first line gives two positive integers N and M (both no more than 104), being the total numbers of vertices and the edges, respectively. Then M lines follow, each describes an edge by giving the indices (from 0 to N-1) of the two ends of the edge.
    After the graph, a positive integer K (<= 100) is given, which is the number of queries. Then K lines of queries follow, each in the format:Nv v[1] v[2] ... v[Nv]
    where Nv is the number of vertices in the set, and v[i]'s are the indices of the vertices.

    Output Specification:
    For each query, print in a line "Yes" if the set is a vertex cover, or "No" if not.

    Sample Input:
    10 11
    8 7
    6 8
    4 5
    8 4
    8 1
    1 2
    1 4
    9 8
    9 1
    1 0
    2 4
    5
    4 0 3 8 4
    6 6 1 7 5 4 9
    3 1 8 4
    2 2 8

    7 9 8 7 6 5 4 2


    Sample Output:
    No
    Yes
    Yes
    No

    No


    题目大意:n个顶点和m条边的图,分别给出m条边的两端顶点,然后对其进行k次查询,每次查询输入一个顶点集合,要求判断这个顶点集合是否能完成顶点覆盖,即图中的每一条边都至少有一个顶点在这个集合中。


    主要思路:这道题最关键的就是图的建立,这里图的输入并不是给出的顶点及其邻接点的关系,而是给出所有边的两端顶点,如果仍然用二维矩阵的方法构造,后续的操作很容易就超时。这里用一个二维的vector容器,对于图中的每个点,添加其所有关联的边,用0 ~ m-1代表所有的m条边,图模型就构造好了。接着,对于点覆盖问题,可以转化成判断集合中每个点所关联的边加起来是否等于图的边数m,由于这里边不能重复,自然而然想到set容器,将要查询的集合中每个点的所有关联边加入set,如果数量等于图的边数m,则完成顶点覆盖,否则不能。

    #include <iostream>
    #include <vector>
    #include <set>
    using namespace std;
    int main(void) {
        int n, m, i, j;
        
        cin >> n >> m;
        vector<vector<int> > edge(n);	
        for (i = 0; i < m; i++) {
            int v, w;
            cin >> v >> w;
            edge[v].push_back(i);
            edge[w].push_back(i);
        }
        
        int k, nv, ver, t;
        set<int> s;
        cin >> k;
        for (i = 0; i < k; i++) {
            cin >> nv;
            for (j = 0; j < nv; j++) {
                cin >> ver;
    			for (t = 0; t < edge[ver].size(); t++)
    				s.insert(edge[ver][t]);
            }
            if (s.size() == m)  cout << "Yes" << endl;
            else                cout << "No" << endl;
            s.clear();                  //清空set集合
        }
        
        return 0;
    }


    总结:构造模型时不要定式思维;关于查询,尽量用少的数据去多的数据里查,避免从多的数据往少的数据里查。

  • 相关阅读:
    cookie的过期时间
    Cookie的使用及位置
    用存储过程进行的查询拼接
    验证码的使用
    SQLHelper
    App_code的引用
    GridView使用
    javascript、ajax验证
    数据库小结(三)
    数据库操作(七)存储过程
  • 原文地址:https://www.cnblogs.com/zhayujie/p/12941580.html
Copyright © 2020-2023  润新知