• TOJ1601. Box of Bricks


    1601.   Box of Bricks
    Time Limit: 1.0 Seconds   Memory Limit: 65536K
    Total Runs: 5002   Accepted Runs: 1949

    Little Bob likes playing with his box of bricks. He puts the bricks one upon another and builds stacks of different height. "Look, I've built a wall!", he tells his older sister Alice. "Nah, you should make all stacks the same height. Then you would have a real wall.", she retorts. After a little consideration, Bob sees that she is right. So he sets out to rearrange the bricks, one by one, such that all stacks are the same height afterwards. But since Bob is lazy he wants to do this with the minimum number of bricks moved. Can you help?

    Input

    The input consists of several data sets. Each set begins with a line containing the number n of stacks Bob has built. The next line contains n numbers, the heights hi of the n stacks. You may assume 1 ≤ n ≤ 50 and 1 ≤ hi ≤ 100.

    The total number of bricks will be divisible by the number of stacks. Thus, it is always possible to rearrange the bricks such that all stacks have the same height.

    The input is terminated by a set starting with n = 0. This set should not be processed.


    Output

    For each set, first print the number of the set, as shown in the sample output. Then print the line "The minimum number of moves is k.", where k is the minimum number of bricks that have to be moved in order to make all the stacks the same height.

    Output a blank line after each set.


    Sample Input

    6
    5 2 4 1 7 5
    0
    


    Sample Output

    Set #1
    The minimum number of moves is 5.
    View Code
    #include<iostream>
    #include<math.h>
    using namespace std;
    #include<string.h>
    int shu[60];
    int main()
    {
        int n,i,aver,k=1,t,ok=1;
        while(cin>>n&&n)
        {
           
           aver=0;t=0;
           for(i=0;i<n;i++)
             cin>>shu[i];
           //if(ok>1)cout<<endl;
           for(i=0;i<n;i++)
             aver+=shu[i];
           aver/=n;
           for(i=0;i<n;i++)
           t+=fabs(aver-shu[i]);
           
           cout<<"Set #"<<ok<<endl;
           cout<<"The minimum number of moves is ";
           cout<<t/2<<'.'<<endl<<endl;
           ok++;
        }
        return 0;
    }
    
    
           
             
        



  • 相关阅读:
    R语言修改vector、matrix、dataframe列名
    R语言获取数据框的行数
    R语言的which函数,针对没有符合条件的返回值为integer(0),之后如何判断
    ArrayList总结
    经常涉及到的技术
    今天开始写博客啦!(测试..)
    [摘转] JS 数组合并问题
    t_category
    在 MySql 的 update 语句中使用 case when else end
    JSP 取当前时间
  • 原文地址:https://www.cnblogs.com/zhaojiedi1992/p/zhaojiedi_2012_08_01000.html
Copyright © 2020-2023  润新知