• nyoj1008 Elevator


    Elevator

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 24439    Accepted Submission(s): 13116


    Problem Description
    The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

    For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.
     
    Input
    There are multiple test cases. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100. A test case with N = 0 denotes the end of input. This test case is not to be processed.
     
    Output
    Print the total time on a single line for each test case. 
     
    Sample Input
    1 2 3 2 3 1 0
     
    Sample Output
    17 41
     
    View Code
    #include <stdio.h>
    int main()
    {
        int floor,number,sum,i,n;
        while(scanf("%d",&n)!=EOF&&n)
        {
            floor=0;
                sum=0;
    
            for(i=0;i<n;i++)
            {
                
                scanf("%d",&number);
                if(number>floor)
                {
                    sum+=(number-floor)*6;
                    sum+=5;
                }
                else
                {
                    sum+=(floor-number)*4;
                    sum+=5;
                }
                floor=number;
            }
            printf("%d\n",sum);
        }
        return 0;
    }
  • 相关阅读:
    音频player
    重要 sdl音最简
    sdl win 播放video hello--
    linux里helloworld
    0129 总结Cygwin要用这个,不要用mingw,根本下不下来
    转音视频重要
    Gradle项目无法下载jar包 修改 插件下载地址plugins.gradle.org

    开源gradle**all.zip下载慢问题
    [Effective Java] 第1条 考虑用静态工厂方法代替构造函数
  • 原文地址:https://www.cnblogs.com/zhaojiedi1992/p/zhaojiedi_2012_05_29.html
Copyright © 2020-2023  润新知