• NYOJ The Triangle


                                                                                            The Triangle

                                                                                                                           时间限制:1000 ms  |  内存限制:65535 KB
                                                                                                                                                               难度:4
    描述

    7
    3 8
    8 1 0
    2 7 4 4
    4 5 2 6 5
    (Figure 1)
    Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right.

    输入
    Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle, all integers, are between 0 and 99.
    输出
    Your program is to write to standard output. The highest sum is written as an integer.
    样例输入
    5
    7
    3 8
    8 1 0 
    2 7 4 4
    4 5 2 6 5
    
    样例输出
    30
    #include <iostream>
    using namespace std;
    const int N = 105;
    
    int a[N][N];
    
    int main(){
      int i,j,n;
      cin>>n;
      for(i=0;i<n;i++){
        for(j=0;j<=i;j++)
           cin>>a[i][j];}
      for(i=n-2;i>=0;i--){
        for(j=0;j<=i;j++)
        a[i][j]+=max(a[i+1][j],a[i+1][j+1]);
      }
      cout<<a[0][0]<<endl;
      return 0;
      }
    
    


  • 相关阅读:
    .NET 2.0 WinForm Control DataGridView 编程36计(一)
    Sql Server 日期格式化函数
    FastReport 金额大小写转换自定义函数
    vue.js 三种方式安装(vuecli)
    Android style
    android ui 布局性能优化
    android 手机分辨率
    TCP,IP,HTTP,SOCKET区别和联系
    android2.2 特性
    常见开放api平台OpenAPI
  • 原文地址:https://www.cnblogs.com/zhangmingzhao/p/7256451.html
Copyright © 2020-2023  润新知