• POJ 1251 换成字母编号的最小生成树


    Agri-Net
    Time Limit: 1000MS   Memory Limit: 10000K
    Total Submissions: 51653   Accepted: 21544

    Description

    Farmer John has been elected mayor of his town! One of his campaign promises was to bring internet connectivity to all farms in the area. He needs your help, of course.
    Farmer John ordered a high speed connection for his farm and is going to share his connectivity with the other farmers. To minimize cost, he wants to lay the minimum amount of optical fiber to connect his farm to all the other farms.
    Given a list of how much fiber it takes to connect each pair of farms, you must find the minimum amount of fiber needed to connect them all together. Each farm must connect to some other farm such that a packet can flow from any one farm to any other farm.
    The distance between any two farms will not exceed 100,000.

    Input

    The input includes several cases. For each case, the first line contains the number of farms, N (3 <= N <= 100). The following lines contain the N x N conectivity matrix, where each element shows the distance from on farm to another. Logically, they are N lines of N space-separated integers. Physically, they are limited in length to 80 characters, so some lines continue onto others. Of course, the diagonal will be 0, since the distance from farm i to itself is not interesting for this problem.

    Output

    For each case, output a single integer length that is the sum of the minimum length of fiber required to connect the entire set of farms.

    Sample Input

    4
    0 4 9 21
    4 0 8 17
    9 8 0 16
    21 17 16 0
    

    Sample Output

    28

    只是把编号换成字母,少点套路,多点真诚行不行?

    #include<iostream>
    #include<cstdlib>
    #include<cstdio>
    #include<cstring>
    #include<algorithm>
    #include<cmath>
    using namespace std;
    int f[27];        //    并查集,用于判断两点是否直接或间接连通
    struct edge {
        int u;
        int v;
        int w;
    }map[80];//存储边的信息,包括起点/终点/权值
    bool cmp ( edge a , edge b)
    {//排序函数,将边根据权值从小到大排
        return a.w<b.w;
    }
    int getf(int x)
    {//并查集的find,不解释
        if(f[x]==x)
            return x;
        else{
            f[x]=getf(f[x]);
            return f[x];
        }
    }
    int main()
    {
        int n;
        while ( cin >> n , n )
        {
            int i , j ;
            for  ( i = 0 ; i < 27  ; i ++ )
                f[i] = i ;//并查集初始化
            int k = 0 ;
            for ( i = 0 ; i < n - 1 ; i ++ )
            {//构造边的信息
                char str[3];
                int m;
                cin >> str >> m ;
                for ( j = 0 ; j < m ; j ++ ,k ++ )
                {
                    char str2[3];
                    int t;
                    cin >> str2 >> t ;
                    map[k].u=(str[0]-'A');
                    map[k].v=(str2[0]-'A');
                    map[k].w=t;
                }
            }
    
            sort ( map , map + k , cmp );//将边从小到大排序
            int ans=0;        //所要求的答案
            for ( i = 0 ; i < k ; i ++ )
            {
                int x = getf(map[i].u);
                int y = getf(map[i].v);
                if( x!=y)
                {//如果两点不在同一连通分量里,则将两点连接,并存储该边
                    ans+=map[i].w;
                    f[x]=y;
                }
            }
            cout<<ans<<endl;
        }
        return 0;
    }
    




  • 相关阅读:
    C++之用程序理解浅拷贝
    es6 | 新增语法 | 总结
    http协议 | http缓存
    Mobx | 强大的状态管理工具 | 可以用Mobx来替代掉redux
    nohup和&后台运行,进程查看及终止
    MIME Type介绍 Content-Type 各种定义
    Meta http-equiv属性详解(转)
    sublme text 3 快捷键
    【坑】【数组的坑】1、对象assign复制的假深度,2、数组slice复制的坑,3、还有数组map复制的坑
    Proxy监听对象的数据变化,处理绑定数据很有用
  • 原文地址:https://www.cnblogs.com/zhangmingzhao/p/7256409.html
Copyright © 2020-2023  润新知