• AOJ GRL_1_A: Single Source Shortest Path (Dijktra算法求单源最短路径,邻接表)


    题目链接:http://judge.u-aizu.ac.jp/onlinejudge/description.jsp?id=GRL_1_A

    Single Source Shortest Path

     

    Input

    An edge-weighted graph G (VE) and the source r.

    |V| |E| r
    s0 t0 d0
    s1 t1 d1
    :
    s|E|−1 t|E|−1 d|E|−1
    

    |V| is the number of vertices and |E| is the number of edges in G. The graph vertices are named with the numbers 0, 1,..., |V|−1 respectively. r is the source of the graph.

    si and ti represent source and target vertices of i-th edge (directed) and di represents the cost of the i-th edge.

    Output

    c0
    c1
    :
    c|V|−1
    

    The output consists of |V| lines. Print the cost of the shortest path from the source r to each vertex 0, 1, ... |V|−1 in order. If there is no path from the source to a vertex, print INF.

    Constraints

    • 1 ≤ |V| ≤ 100000
    • 0 ≤ di ≤ 10000
    • 0 ≤ |E| ≤ 500000
    • There are no parallel edges
    • There are no self-loops

    Sample Input 1

    4 5 0
    0 1 1
    0 2 4
    1 2 2
    2 3 1
    1 3 5
    

    Sample Output 1

    0
    1
    3
    4
    

     

    Sample Input 2

    4 6 1
    0 1 1
    0 2 4
    2 0 1
    1 2 2
    3 1 1
    3 2 5
    

    Sample Output 2

    3
    0
    2
    INF







    这题数据范围比较大,最多有100000个顶点,用邻接矩阵表示的话,空间肯定会超限。
    我用Dijiksra的邻接表来解了。


    套一个模板就出来了:
    #include <iostream>
    #include <algorithm>
    #include <map>
    #include <vector>
    using namespace std;
    typedef long long ll;
    #define INF 2147483647
    
    struct edge{
        int to,cost;
    };
    int V,E; 
    
    vector <edge> G[100010];
    
    multimap <int,int> l;
    
    
    ll d[500010];
    
    
    void dijkstra(int s){
        fill(d,d+V,INF);
        d[s] = 0;
        
        l.insert(make_pair(0,s));
        
        while(l.size() > 0){
            int p = l.begin()->first;
            int v = l.begin()->second;
            l.erase(l.begin());
            
            if(d[v] < p) continue;
            
            for(int i = 0;i < G[v].size(); i++){
                edge e = G[v][i];
                if(d[e.to] > d[v] + e.cost){
                    d[e.to] = d[v] + e.cost;
                    l.insert(make_pair(d[e.to], e.to));
                }
            }
        }
    }
    
    
    int main(){
        
        int r;
        cin >> V >> E >> r;
        for(int i = 0;i < E; i++){
             edge e;
            int from;
            cin >> from >> e.to >> e.cost;
            G[from].push_back(e);
        }
        
        dijkstra(r);
        
        for(int i = 0;i < V; i++){
            if(d[i] != INF) cout << d[i] << endl;
            else cout << "INF" <<endl;
        }
        return 0;
    } 
     
  • 相关阅读:
    合并2个dll成一个,好处你懂的
    来吧,给你的Winform列表控件画个妆
    DataGridView 的cell赋值没有线程间访问的限制吗?
    设计模式之单例模式
    一个铜钱的故事(转)
    博客美化小结
    FTP操作类(支持异步)
    多线程学习之AsyncOperation实现线程间交互
    消息传递选择:返回值 or 抛出异常
    IIS8.5关于“ 配置错误 不能在此路径中使用此配置节”的解决办法
  • 原文地址:https://www.cnblogs.com/zhangjiuding/p/7726089.html
Copyright © 2020-2023  润新知