• POJ 3617 Best Cow Line 贪心算法


    Best Cow Line
    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 26670   Accepted: 7226

    Description

    FJ is about to take his N (1 ≤ N ≤ 2,000) cows to the annual"Farmer of the Year" competition. In this contest every farmer arranges his cows in a line and herds them past the judges.

    The contest organizers adopted a new registration scheme this year: simply register the initial letter of every cow in the order they will appear (i.e., If FJ takes Bessie, Sylvia, and Dora in that order he just registers BSD). After the registration phase ends, every group is judged in increasing lexicographic order according to the string of the initials of the cows' names.

    FJ is very busy this year and has to hurry back to his farm, so he wants to be judged as early as possible. He decides to rearrange his cows, who have already lined up, before registering them.

    FJ marks a location for a new line of the competing cows. He then proceeds to marshal the cows from the old line to the new one by repeatedly sending either the first or last cow in the (remainder of the) original line to the end of the new line. When he's finished, FJ takes his cows for registration in this new order.

    Given the initial order of his cows, determine the least lexicographic string of initials he can make this way.

    Input

    * Line 1: A single integer: N
    * Lines 2..N+1: Line i+1 contains a single initial ('A'..'Z') of the cow in the ith position in the original line

    Output

    The least lexicographic string he can make. Every line (except perhaps the last one) contains the initials of 80 cows ('A'..'Z') in the new line.

    Sample Input

    6
    A
    C
    D
    B
    C
    B

    Sample Output

    ABCBCD






    思路:从左Left和从右Right同时开始扫,如果如果左边的值小于右边的值,则输出左边的,Left++。
      如果左边的值大于右边的值,则输出右边的,Right++。
      如果左边的值等于右边的值,则比较从左往右形成的字符串和从右往左形成的字符串哪个更小。输出小的那边的,改变Left或者Right。



    代码:
    #include <iostream> 
    using namespace std;
    typedef long long ll;
    
    int n;
    char a[2010];
    
    int main() {
        cin >> n;
        for(int i = 0;i < n; i++) cin >> a[i];
    
        string s;
        
        int left = 0;int right = n-1;
        while(left <= right){
            int l = false;
            for(int i = 0;i <= right - left; i++){
                if(a[left+i] < a[right-i]){
                    l = true;
                }
                if(a[left+i] != a[right-i]){
                    break;
                }
            }
            
            if(l) s += a[left++];
            else s += a[right--];
        } 
        for(int i = 0;s[i]; i++){
            if(i != 0&&i%80 == 0) cout << endl;
            cout << s[i];
        }
        
      return 0;
    }
    //  writen by zhangjiuding
     
  • 相关阅读:
    利用SEH进行代码混淆
    HDU5294 Tricks Device(最大流+SPFA) 2015 Multi-University Training Contest 1
    输入字符串反序输出
    微信公众平台开发(104) 自定义菜单扫一扫、发图片、发地理位置
    不同编码页面之间表单的提交方法
    PHP登陆Session验证
    微信公众平台开发培训
    微信公众平台开发(98) UnionID
    微信电商再侵袭,腾讯要革淘宝的命
    微信企业号
  • 原文地址:https://www.cnblogs.com/zhangjiuding/p/7663724.html
Copyright © 2020-2023  润新知