• 1061 Dating (20 分)


    1061 Dating (20 分)

    Sherlock Holmes received a note with some strange strings: Let's date! 3485djDkxh4hhGE 2984akDfkkkkggEdsb s&hgsfdk d&Hyscvnm. It took him only a minute to figure out that those strange strings are actually referring to the coded time Thursday 14:04 -- since the first common capital English letter (case sensitive) shared by the first two strings is the 4th capital letter D, representing the 4th day in a week; the second common character is the 5th capital letter E, representing the 14th hour (hence the hours from 0 to 23 in a day are represented by the numbers from 0 to 9 and the capital letters from A to N, respectively); and the English letter shared by the last two strings is s at the 4th position, representing the 4th minute. Now given two pairs of strings, you are supposed to help Sherlock decode the dating time.

    Input Specification:

    Each input file contains one test case. Each case gives 4 non-empty strings of no more than 60 characters without white space in 4 lines.

    Output Specification:

    For each test case, print the decoded time in one line, in the format DAY HH:MM, where DAY is a 3-character abbreviation for the days in a week -- that is, MON for Monday, TUE for Tuesday, WED for Wednesday, THU for Thursday, FRI for Friday, SAT for Saturday, and SUN for Sunday. It is guaranteed that the result is unique for each case.

    Sample Input:

    3485djDkxh4hhGE 
    2984akDfkkkkggEdsb 
    s&hgsfdk 
    d&Hyscvnm
    

    Sample Output:

    THU 14:04
    思路
      注意判断字符的范围
    #include<iostream>
    #include<vector>
    #include<algorithm>
    #include<map>
    #include<set>
    #include<cmath>
    #include<climits>
    #include<sstream>
    #include<cstdio>
    #include<string.h>
    using namespace std;
    
    
    
    
    
    int main()
    {
        string str1,str2,str3,str4;
        cin>>str1>>str2>>str3>>str4;
        char c1,c2;
        int i,len=str1.size();
        for(i=0;i<len;i++)
        {
            if(str2[i]==str1[i]&&str1[i]>='A'&&str2[i]<='G')
            {
                c1=str1[i];
                break;
            }
        }
        for(i=i+1;i<len;i++)
        {
            if(str1[i]>='A'&&str1[i]<='N'&&str2[i]==str1[i])
            {
                c2=str1[i];
                break;
            }
            else if(isdigit(str1[i])&&str1[i]==str2[i])
            {
                c2=str1[i];
                break;
            }
        }
      //  cout<<c2<<endl;
        string day[]={"MON","TUE","WED","THU","FRI","SAT","SUN"};
        printf("%s ",day[c1-'A'].c_str());
        if(isdigit(c2))
        {
            printf("%02d:",c2-'0');
        }
        else
        {
            printf("%02d:",c2-'A'+10);
        }
        for(i=0;i<str3.size();i++)
        {
          if(str3[i]==str4[i]&&isalpha(str3[i]))
                break;
        }
        printf("%02d",i);
        return 0;
    }
     
  • 相关阅读:
    linux中的信号机制
    函数指针读书笔记
    const读书笔记
    动态规划----0/1背包问题
    函数指针的用法---以冒泡排序为例
    各种排序算法的实现(更新中)
    Flutter滚动型容器组件
    Flutter json转实体类(插件自动生成)
    Flutter 键盘弹出背景图片变形
    Flutter BottomNavigationBar切换页面被重置问题(保存状态)
  • 原文地址:https://www.cnblogs.com/zhanghaijie/p/10342272.html
Copyright © 2020-2023  润新知