• 1037 Magic Coupon (25 分)


    The magic shop in Mars is offering some magic coupons. Each coupon has an integer N printed on it, meaning that when you use this coupon with a product, you may get N times the value of that product back! What is more, the shop also offers some bonus product for free. However, if you apply a coupon with a positive N to this bonus product, you will have to pay the shop N times the value of the bonus product... but hey, magically, they have some coupons with negative N's!

    For example, given a set of coupons { 1 2 4 − }, and a set of product values { 7 6 − } (in Mars dollars M$) where a negative value corresponds to a bonus product. You can apply coupon 3 (with N being 4) to product 1 (with value M$7) to get M$28 back; coupon 2 to product 2 to get M$12 back; and coupon 4 to product 4 to get M$3 back. On the other hand, if you apply coupon 3 to product 4, you will have to pay M$12 to the shop.

    Each coupon and each product may be selected at most once. Your task is to get as much money back as possible.

    Input Specification:

    Each input file contains one test case. For each case, the first line contains the number of coupons NC​​, followed by a line with NC​​ coupon integers. Then the next line contains the number of products NP​​, followed by a line with NP​​ product values. Here 1, and it is guaranteed that all the numbers will not exceed 230​​.

    Output Specification:

    For each test case, simply print in a line the maximum amount of money you can get back.

    Sample Input:

    4
    1 2 4 -1
    4
    7 6 -2 -3
    

    Sample Output:

    43

    #include<iostream>
    #include<vector>
    #include<algorithm>
    #include<queue>
    #include<string>
    #include<map>
    #include<set>
    #include<stack>
    #include<string.h>
    #include<cstdio>
    #include<cmath>
    using namespace std;
    
    
    
    
    
    
    
    int main()
    {
        int nc;
        scanf("%d",&nc);
        vector<int> coupons(nc);
        for(int i=0; i<nc; i++)
        {
            scanf("%d",&coupons[i]);
        }
        int np;
        scanf("%d",&np);
        vector<int>products(np);
        //products.resize(np);
        for(int i=0; i<np; i++)
        {
            scanf("%d",&products[i]);
        }
        sort(coupons.begin(),coupons.end(),greater<int>());
    
        sort(products.begin(),products.end(),greater<int>());
        int sum=0;
        for(int i=0; i<nc&&i<np; i++)
        {
           // cout<<coupons[i];
            if(coupons[i]>0&&products[i]>0)
                sum+=coupons[i]*products[i];
            else
                break;
        }
        reverse(coupons.begin(),coupons.end());
        reverse(products.begin(),products.end());
        for(int i=0; i<nc&&i<np; i++)
        {
            if(coupons[i]<0&&products[i]<0)
                sum+=coupons[i]*products[i];
            else
                break;
        }
        cout<<sum<<endl;
        return 0;
    }
  • 相关阅读:
    期中架构实现步骤
    安装centos以及优化步骤
    inotify+rsync实现实时热备
    [转]ubuntu安装vncserver实现图形化访问
    [转]电烙铁的使用小技巧
    彻底解决 LINK : fatal error LNK1123: 转换到 COFF 期间失败: 文件无效或损坏
    解读系统托盘图标隐藏(删除)
    一个小公式帮你轻松将IP地址从10进制转到2进制
    [查阅]Dalvik opcodes
    [查阅]MSIL Instruction Set
  • 原文地址:https://www.cnblogs.com/zhanghaijie/p/10324756.html
Copyright © 2020-2023  润新知