• 1032 Sharing (25 分)使用set实现


    1032 Sharing (25 分)

    To store English words, one method is to use linked lists and store a word letter by letter. To save some space, we may let the words share the same sublist if they share the same suffix. For example, loading and being are stored as showed in Figure 1.

    fig.jpg

    Figure 1

    You are supposed to find the starting position of the common suffix (e.g. the position of i in Figure 1).

    Input Specification:

    Each input file contains one test case. For each case, the first line contains two addresses of nodes and a positive N (105​​), where the two addresses are the addresses of the first nodes of the two words, and N is the total number of nodes. The address of a node is a 5-digit positive integer, and NULL is represented by 1.

    Then N lines follow, each describes a node in the format:

    Address Data Next
    

    whereAddress is the position of the node, Data is the letter contained by this node which is an English letter chosen from { a-z, A-Z }, and Next is the position of the next node.

    Output Specification:

    For each case, simply output the 5-digit starting position of the common suffix. If the two words have no common suffix, output -1 instead.

    Sample Input 1:

    11111 22222 9
    67890 i 00002
    00010 a 12345
    00003 g -1
    12345 D 67890
    00002 n 00003
    22222 B 23456
    11111 L 00001
    23456 e 67890
    00001 o 00010
    

    Sample Output 1:

    67890
    

    Sample Input 2:

    00001 00002 4
    00001 a 10001
    10001 s -1
    00002 a 10002
    10002 t -1
    

    Sample Output 2:

    -1
    思路:
      1、这次我参考网上的代码没有使用map,而是使用结构体数组。不同之处在于,我没有使用visit这个变量,而是在遍历第一个链表的时候
    把地址放在了set中,遍历第二个链表的时候在set中查找地址,如果有直接输出,没有的话则输出-1.当然时间复杂度会大一点,但是略微好
    思考一点,还好这次通过了。
    #include<iostream>
    #include<vector>
    #include<algorithm>
    #include<queue>
    #include<string>
    #include<map>
    #include<set>
    using namespace std;
    set<int> s;
    struct Node
    {
       // int start;
        char data;
        int next;
    }node[1000000];
    
    
    
    int main()
    {
        int addressA,addressB,n;
        scanf("%d%d%d",&addressA,&addressB,&n);
        for(int i=0;i<n;i++)
        {
            int start;
            scanf("%d",&start);
            scanf(" %c%d",&node[start].data,&node[start].next);
        }
        for(int i=addressA;i!=-1;i=node[i].next)
            s.insert(i);
        for(int i=addressB;i!=-1;i=node[i].next)
        {
            if(s.find(i)!=s.end())
            {
                printf("%05d",i);
                return 0;
            }
        }
        printf("-1");
        return 0;
    }
     
  • 相关阅读:
    利用递归分割(Split)字符串
    SQL Server2012 T-SQL基础教程--读书笔记(1-4章)
    kindeditor编辑器的使用
    echarts绘制四川地图
    Windows下搭建PHP开发环境(Apache+PHP+MySQL)+调试工具Xdebug的配置
    给搜索关键字添加高亮,加以颜色区分
    SQL 生成6位随机数并MD5加密输出
    微信小程序登录 .net 后端实现
    钉钉小程序http post 请求
    浅谈Web Api配合SignalR的跨域支持
  • 原文地址:https://www.cnblogs.com/zhanghaijie/p/10299636.html
Copyright © 2020-2023  润新知