• poj 1251 Jungle Roads (最小生成树)


    poj   1251  Jungle Roads  (最小生成树)

    Link: http://poj.org/problem?id=1251 

    Jungle Roads

    Time Limit: 1000MS

     

    Memory Limit: 10000K

    Total Submissions: 23507

     

    Accepted: 11012

    Description

     

    The Head Elder of the tropical island of Lagrishan has a problem. A burst of foreign aid money was spent on extra roads between villages some years ago. But the jungle overtakes roads relentlessly, so the large road network is too expensive to maintain. The Council of Elders must choose to stop maintaining some roads. The map above on the left shows all the roads in use now and the cost in aacms per month to maintain them. Of course there needs to be some way to get between all the villages on maintained roads, even if the route is not as short as before. The Chief Elder would like to tell the Council of Elders what would be the smallest amount they could spend in aacms per month to maintain roads that would connect all the villages. The villages are labeled A through I in the maps above. The map on the right shows the roads that could be maintained most cheaply, for 216 aacms per month. Your task is to write a program that will solve such problems. 

    Input

    The input consists of one to 100 data sets, followed by a final line containing only 0. Each data set starts with a line containing only a number n, which is the number of villages, 1 < n < 27, and the villages are labeled with the first n letters of the alphabet, capitalized. Each data set is completed with n-1 lines that start with village labels in alphabetical order. There is no line for the last village. Each line for a village starts with the village label followed by a number, k, of roads from this village to villages with labels later in the alphabet. If k is greater than 0, the line continues with data for each of the k roads. The data for each road is the village label for the other end of the road followed by the monthly maintenance cost in aacms for the road. Maintenance costs will be positive integers less than 100. All data fields in the row are separated by single blanks. The road network will always allow travel between all the villages. The network will never have more than 75 roads. No village will have more than 15 roads going to other villages (before or after in the alphabet). In the sample input below, the first data set goes with the map above. 

    Output

    The output is one integer per line for each data set: the minimum cost in aacms per month to maintain a road system that connect all the villages. Caution: A brute force solution that examines every possible set of roads will not finish within the one minute time limit. 

    Sample Input

    9

    A 2 B 12 I 25

    B 3 C 10 H 40 I 8

    C 2 D 18 G 55

    D 1 E 44

    E 2 F 60 G 38

    F 0

    G 1 H 35

    H 1 I 35

    3

    A 2 B 10 C 40

    B 1 C 20

    0

    Sample Output

    216

    30

    Source

    Mid-Central USA 2002

     

    题意:

    给定多个点,和点与点之间的距离, 求最小让其连接起来的线路的总和。

     

    经典的最小生成树问题。 使用 prime算法。

    prime算法:

    隔离出已经访问的点和未访问的点,寻找到访问过的点的树中到未访问点的最小距离,收之, 生成一个树, 继续。

    // 1251 
    #include <iostream> 
    #include <cstdio>
    #include <cstdlib> 
    #include <cstring> 
    using namespace std;
    const int maxn = 30; 
    
    int n, mp[maxn][maxn];  
    
    int Prime(int cur){
    	int i,j, minlen, sum, pt = cur, dist[maxn];
    	bool visited[maxn]; 
    	memset(visited, false, sizeof(visited)); 
    	visited[cur] = true; 
    	sum = 0; 
    	for(i=0; i<n; i++){
    		dist[i] = mp[cur][i]; 
    	}
    	for(i=1; i<n; i++){
    		minlen = 0x3f3f3f3f; 
    		for(j=0; j<n; j++){
    			if(!visited[j] && minlen > dist[j]){
    				minlen = dist[j]; 
    				pt = j; 
    			}
    		}
    		visited[pt] = true; 
    		sum += minlen; 
    		for(j=0; j<n; j++){
    			if(!visited[j] && dist[j] > mp[pt][j]){
    				dist[j] = mp[pt][j]; 
    			}
    		}
    	}
    	return sum; 
    }
    
    int main(){
    	freopen("in.txt", "r", stdin); 
    
    	int i,j, num2, num1, ans;
    	char ch1, ch2; 
    	while(cin>>n && n){
    		memset(mp, 0x3f3f3f3f, sizeof(mp)); 
    		for(i=1; i<n; i++){
    			cin>>ch1>>num1;
    			for(j=1; j<=num1; j++){
    				cin>>ch2>>num2; 
    				mp[ch1-'A'][ch2-'A'] = mp[ch2-'A'][ch1-'A'] = num2; 
    			}
    		}
    		ans = Prime(ch1-'A'); 
    		cout<<ans<<endl; 
    	}
    	return 0; 
    }
    

     

  • 相关阅读:
    终于干掉了默认的输入法, 关于ctfmon.exe文件
    新工作一周的一些记录
    派送Maxthon 2.0 社区预览版本邀请.
    终于决定要跳槽了.
    当QA推出免责条款, 你会怎么看?
    Post by Word 2007, Test. 用word2007来发表一篇随笔.
    一个好的点菜系统
    再见2006
    昨天的实况以及忽悠姐妹花
    在公司我最近都只喝矿泉水
  • 原文地址:https://www.cnblogs.com/zhang-yd/p/6060899.html
Copyright © 2020-2023  润新知