• poj 1258 Agri-Net


    Agri-Net
    Time Limit: 1000MS   Memory Limit: 10000K
    Total Submissions: 38809   Accepted: 15676

    Description

    Farmer John has been elected mayor of his town! One of his campaign promises was to bring internet connectivity to all farms in the area. He needs your help, of course. 
    Farmer John ordered a high speed connection for his farm and is going to share his connectivity with the other farmers. To minimize cost, he wants to lay the minimum amount of optical fiber to connect his farm to all the other farms. 
    Given a list of how much fiber it takes to connect each pair of farms, you must find the minimum amount of fiber needed to connect them all together. Each farm must connect to some other farm such that a packet can flow from any one farm to any other farm. 
    The distance between any two farms will not exceed 100,000. 

    Input

    The input includes several cases. For each case, the first line contains the number of farms, N (3 <= N <= 100). The following lines contain the N x N conectivity matrix, where each element shows the distance from on farm to another. Logically, they are N lines of N space-separated integers. Physically, they are limited in length to 80 characters, so some lines continue onto others. Of course, the diagonal will be 0, since the distance from farm i to itself is not interesting for this problem.

    Output

    For each case, output a single integer length that is the sum of the minimum length of fiber required to connect the entire set of farms.

    Sample Input

    4
    0 4 9 21
    4 0 8 17
    9 8 0 16
    21 17 16 0
    

    Sample Output

    28


    最小生成树(Prim算法):

    #include<stdio.h>
    #include<iostream>
    #include<algorithm>
    #include<math.h>
    #define INF 999999
    #define M 105
    using namespace std;
    
    int map[M][M],dis[M];   
    int vis[M];
    
    int main ()
    {
    	int n;
    	int i,j;
    	int temp,sum ;
    	while(cin>>n)
    	{
    		memset(map,0,sizeof(map));
    		memset(vis,0,sizeof(vis));
    		
    		for(i=1;i<=n;i++)
    			for(j=1;j<=n;j++)
    				cin>>map[i][j];
    		
    			for(i=1;i<=n;i++)
    				dis[i]=map[1][i];
    			
    			vis[1]=1;
    			sum=0;
    
    			for(i=1;i<n;i++)
    			{ 
    				int min=INF;
    				for(j=1;j<=n;j++)
    				{
    					if(!vis[j] && dis[j]<min)
    					{
    						min=dis[j];
    						temp=j;	
    					}
    				}
    				sum+=min;
    				vis[temp]=1;
    				
    				for(j=1;j<=n;j++)
    				{
    					if(!vis[j] && dis[j]>map[temp][j])
    						dis[j]=map[temp][j];
    				}
    			}
    			cout<<sum<<endl;
    	}
    	return 0;
    }




  • 相关阅读:
    [usaco]Cow Pedigrees
    组合数取模
    [usaco]Controlling Companies
    ubuntu g++ 升级
    膜拜
    Node.js权威指南 (2)
    Vue.js 开发环境的搭建
    src路径问题:./ 与 ../
    vscode vue代码提示错误
    H5 localStorage sessionStorage
  • 原文地址:https://www.cnblogs.com/zfyouxi/p/4072774.html
Copyright © 2020-2023  润新知