• Linearization of the kernel functions in SVM


    SVM(Support Vector Machine)is an important classification tool, which has a wide range of applications in cluster analysis, community division and so on. SVM The kernel functions used in SVM have many forms. Here we only discuss the function of the form f(x,y,z) = ax^2 + by^2 + cy^2 + dxy + eyz + fzx + gx + hy + iz + j. By introducing new variables p, q, r, u, v, w, the linearization of the function f(x,y,z) is realized by setting the correspondence x^2 <-> p, y^2 <-> q, z^2 <-> r, xy <-> u, yz <-> v, zx <-> w and the function f(x,y,z) = ax^2 + by^2 + cy^2 + dxy + eyz + fzx + gx + hy + iz + j can be written as g(p,q,r,u,v,w,x,y,z) = ap + bq + cr + du + ev + fw + gx + hy + iz + j, which is a linear function with 9 variables. 

    Now your task is to write a program to change f into g.

    InputThe input of the first line is an integer T, which is the number of test data (T<120). Then T data follows. For each data, there are 10 integer numbers on one line, which are the coefficients and constant a, b, c, d, e, f, g, h, i, j of the function f(x,y,z) = ax^2 + by^2 + cy^2 + dxy + eyz + fzx + gx + hy + iz + j.OutputFor each input function, print its correspondent linear function with 9 variables in conventional way on one line.Sample Input

    2
    0 46 3 4 -5 -22 -8 -32 24 27
    2 31 -5 0 0 12 0 0 -49 12

    Sample Output

    46q+3r+4u-5v-22w-8x-32y+24z+27
    2p+31q-5r+12w-49z+12
    //注意前面数都为0,后面符号问题,1 -1没有1,第一个的符号问题
    
    #include<stdio.h>
    #include<string.h>
    int main()
    {
        char a[10]={'p','q','r','u','v','w','x','y','z'};
        int b[10],i,n;
        scanf("%d",&n);
        while(n--)
        {
            int m=0;
            for(i=0;i<=9;i++)
                scanf("%d",&b[i]);
            for(i=0;i<=9;i++)
            {
                if(b[i]==0)
                    continue;
                if(m==0)
                {
                    if(b[i]==1&&i!=9)
                        printf("%c",a[i]);
                    else
                    if(b[i]==-1&&i!=9)
                       printf("-%c",a[i]);
                    else
                    if(i!=9)
                       printf("%d%c",b[i],a[i]);
                }
                else
                {
                    if(b[i]==1&&i!=9)
                        printf("+%c",a[i]),m++;
                    else
                    if(b[i]==-1&&i!=9)
                       printf("-%c",a[i]);
                    else
                    if(b[i]>0&&i!=9)
                       printf("+%d%c",b[i],a[i]);
                    else
                    if(b[i]<0&&i!=9)
                       printf("%d%c",b[i],a[i]);
                }
                if(i==9)
                {
                    if(m==0)
                        printf("%d",b[i]);
                    else
                    {
                        if(b[i]>0)
                            printf("+");
                        printf("%d",b[i]);
                    }
                }
                m++;
            }
            puts("");
        }
    }

     


     

  • 相关阅读:
    map 取最大value
    tmux 常用快捷键
    史蒂夫 乔布斯(Steve Jobs)在 Stanford 2005年毕业典礼上的演讲(中英文对照)
    黄聪:WordPress后台添加侧边栏菜单(WP教程add_menu_page)
    黄聪:ASP.NET AJAX入门系列(1) AjaxControlToolkit安装篇
    黄聪:ASP.NET AJAX入门系列(2) Accordion控件
    黄聪:wordpress调用函数大全
    黄聪:使用Wordpress中的wpdb类操作数据库
    黄聪:C#的Microsoft图表控件
    黄聪:如何写出兼容性强的CSS代码,适应各种浏览器:IE、火狐等
  • 原文地址:https://www.cnblogs.com/zcy19990813/p/9702803.html
Copyright © 2020-2023  润新知