Description
输入一个字符串,空格作为单词分隔符,统计其中的单词,并将单词逆序输出
Input
输入一个字符串
Output
逆序输出单词
Sample Input
I love you!
Sample Output
you love I!
本程序只限于后面有标点符号的
#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<string.h>
using namespace std;
int main()
{
char a[100],t[100][100];
int i,j,e=0,k=0;
gets(a);
int n=strlen(a);
for(i=0;i<n;i++)
{
if(a[i]==' ')
{
e++;
k=0;
continue;
}
if((a[i]>='a'&&a[i]<='z')||(a[i]>='A'&&a[i]<='Z'))
t[e][k++]=a[i];
}
for(i=e; i>=0; i--)
{
if(i==0)
printf("%s",t[i]);
else
printf("%s ",t[i]);
}
putchar(a[strlen(a)-1]);
putchar('
');
return 0;
}