• Binary Tree Traversals


    A binary tree is a finite set of vertices that is either empty or consists of a root r and two disjoint binary trees called the left and right subtrees. There are three most important ways in which the vertices of a binary tree can be systematically traversed or ordered. They are preorder, inorder and postorder. Let T be a binary tree with root r and subtrees T1,T2. 

    In a preorder traversal of the vertices of T, we visit the root r followed by visiting the vertices of T1 in preorder, then the vertices of T2 in preorder. 

    In an inorder traversal of the vertices of T, we visit the vertices of T1 in inorder, then the root r, followed by the vertices of T2 in inorder. 

    In a postorder traversal of the vertices of T, we visit the vertices of T1 in postorder, then the vertices of T2 in postorder and finally we visit r. 

    Now you are given the preorder sequence and inorder sequence of a certain binary tree. Try to find out its postorder sequence. 

    InputThe input contains several test cases. The first line of each test case contains a single integer n (1<=n<=1000), the number of vertices of the binary tree. Followed by two lines, respectively indicating the preorder sequence and inorder sequence. You can assume they are always correspond to a exclusive binary tree. 
    OutputFor each test case print a single line specifying the corresponding postorder sequence. 
    Sample Input

    9
    1 2 4 7 3 5 8 9 6
    4 7 2 1 8 5 9 3 6

    Sample Output

    7 4 2 8 9 5 6 3 1

    思路很简单,但是输出的地方老是OLE;最后还是学长帮忙改的,,,
    #include <stdio.h>
    #include <stdlib.h>
    #include <cmath>
    #include <cstring>
    #include <iostream>
    #include<algorithm>
    #include <queue>
    #include <map>
    #include <vector>
    #include <cmath>
    #define INF 0x3f3f3f3f
    using namespace std;
    #define N  2000005
    
    int n, a[N], b[N], f[N],op;
    
    void solve(int root, int s, int e,int index)
    {
        int p;
        if(s>e)
        {
            return;
        }
    
        for(int i=1; i<=n; i++)
        {
            if(b[i]==a[root])
            {
                p=i;
    
                break;
            }
        }
        solve(root+1, s, p-1,index*2);
        solve(root+p+1-s, p+1, e,index*2+1);
        if(!op)///这里在遍历的时候就输出父节点
        {
            op = 1;
            printf("%d",a[root]);
        }
        else
        {
            printf(" %d",a[root]);
        }
    }
    
    int main()
    {
        int i;
        while(scanf("%d", &n)!=EOF)
        {
            op = 0;
            memset(f, -1, sizeof(f));
            memset(a, -1, sizeof(a));
            memset(b, -1, sizeof(b));
            for(i=1; i<=n; i++)
            {
                scanf("%d", &a[i]);
            }
            for(i=1; i<=n; i++)
            {
                scanf("%d", &b[i]);
            }
            solve(1, 1, n, 1);
            printf("\n");
        }
        return 0;
    }
  • 相关阅读:
    [C语言嵌入式系统编程修炼] 软件架构与内存操作篇
    [C陷阱和缺陷] 第2章 语法“陷阱”
    DAO是什么技术
    Java泛型:类型擦除
    Java泛型:泛型类、泛型接口和泛型方法
    定义泛型接口
    java,<E>什么意思?
    java List 去重(两种方式)
    java中List集合及其遍历详解
    java 遍历arrayList的四种方法
  • 原文地址:https://www.cnblogs.com/zct994861943/p/7200709.html
Copyright © 2020-2023  润新知