• 最短路变形。。。。


    Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists' sunscreen, he wants to avoid swimming and instead reach her by jumping. 
    Unfortunately Fiona's stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps. 
    To execute a given sequence of jumps, a frog's jump range obviously must be at least as long as the longest jump occuring in the sequence. 
    The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones. 

    You are given the coordinates of Freddy's stone, Fiona's stone and all other stones in the lake. Your job is to compute the frog distance between Freddy's and Fiona's stone. 

    Input

    The input will contain one or more test cases. The first line of each test case will contain the number of stones n (2<=n<=200). The next n lines each contain two integers xi,yi (0 <= xi,yi <= 1000) representing the coordinates of stone #i. Stone #1 is Freddy's stone, stone #2 is Fiona's stone, the other n-2 stones are unoccupied. There's a blank line following each test case. Input is terminated by a value of zero (0) for n.

    Output

    For each test case, print a line saying "Scenario #x" and a line saying "Frog Distance = y" where x is replaced by the test case number (they are numbered from 1) and y is replaced by the appropriate real number, printed to three decimals. Put a blank line after each test case, even after the last one.

    Sample Input

    2
    0 0
    3 4
    
    3
    17 4
    19 4
    18 5
    
    0
    

    Sample Output

    Scenario #1
    Frog Distance = 5.000
    
    Scenario #2
    Frog Distance = 1.414

    坑爹的英文题。。 这里要求的是到达Fiona所有path的最小必须跳跃距离(the largest edge of paths)
    关键分析 我们用d[v]表示 起点到v点的所有path的最小必须跳跃距离
    那么就有状态转移方程 d[v]=for(j=1~n) if(d[j]<d[v]&&cost(j->v)<d[v]) d[v]=max(cost,d[j])

    状态方程出来, 其实就是最短路的改版。,。 实现过程几乎没有差别、
    上代码:
    kee point: 1.tey to comprehend the meanings of text!
    2. design the stata transition.
    #include<algorithm>
        #include<queue>
        #include<stdio.h>
        #include<string.h>
        #include<vector>
        #include<math.h>
        using namespace std;

        const int maxn = 205;
        const int oo = 0xfffffff;

        struct point{double x, y;}p[maxn];
        struct node
        {
            int y;
            double len;
            node(int y, double len):y(y), len(len){}
        };
        vector<node> G[maxn];
        double v[maxn];

        //求两点间的距离
        double Len(point a, point b)
        {
            return sqrt((a.x-b.x)*(a.x-b.x)+(a.y-b.y)*(a.y-b.y));
        }
        void Spfa()
        {
            queue<int> Q;
            Q.push(1);

            while(Q.size())
            {
                int s = Q.front();Q.pop();
                int len = G[s].size();

                for(int i=0; i<len; i++)
                {
                    node q = G[s][i];

                    if(v[s] < v[q.y] && q.len < v[q.y])
                    {
                        v[q.y] = max(v[s], q.len);//要选取一条路上的最大的那条边
                        Q.push(q.y);
                    }
                }
            }
        }

        int main()
        {
            int N, t=1;

            while(scanf("%d", &N), N)
            {
                int i, j;

                for(i=1; i<=N; i++)
                    scanf("%lf%lf", &p[i].x, &p[i].y);

                for(i=1; i<=N; i++)
                for(j=1; j<=N; j++)
                {
                    if(i == j)
                        continue;

                    double len = Len(p[i], p[j]);
                    G[i].push_back(node(j, len));
                }

                for(i=1; i<=N; i++)
                    v[i] = oo;
                v[1] = 0;

                Spfa();

                if(t != 1)printf(" ");
                printf("Scenario #%d ", t++);
                printf("Frog Distance = %.3f ", v[2]);

                for(i=1; i<=N; i++)
                    G[i].clear();
            }

            return 0;


  • 相关阅读:
    java如何实现以数据流的形式下载压缩包到本地?
    在用easyui中做CRUD功能时,当删除一行或多行数据后再点击修改会提示你选中了多行,如何解决这个bug了?
    windows中当你的键盘无法使用时我们可以用另一种方法哦
    Idea中如何将web项目打包成war包并放到tomcat中启动
    [CSS3] Use media query to split css files and Dark mode (prefers-color-scheme: dark)
    [PWA] Storage information for PWA application
    [HTML5] Native lazy-loading for the web
    [Dynamic Programming] 198. House Robber
    [Javascript] Sort by multi factors
    [Javascript] Keyword 'in' to check prop exists on Object
  • 原文地址:https://www.cnblogs.com/z1141000271/p/6529003.html
Copyright © 2020-2023  润新知