• hdu 5055(坑)


    题目链接:http://acm.hdu.edu.cn/showproblem.php?

    pid=5055

    Bob and math problem

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 695    Accepted Submission(s): 263


    Problem Description
    Recently, Bob has been thinking about a math problem.
    There are N Digits, each digit is between 0 and 9. You need to use this N Digits to constitute an Integer.
    This Integer needs to satisfy the following conditions:
    • 1. must be an odd Integer.
    • 2. there is no leading zero.
    • 3. find the biggest one which is satisfied 1, 2.

    Example:
    There are three Digits: 0, 1, 3. It can constitute six number of Integers. Only "301", "103" is legal, while "130", "310", "013", "031" is illegal. The biggest one of odd Integer is "301".
     

    Input
    There are multiple test cases. Please process till EOF.
    Each case starts with a line containing an integer N ( 1 <= N <= 100 ).
    The second line contains N Digits which indicate the digit $a_1, a_2, a_3, cdots, a_n. ( 0 leq a_i leq 9)$.
     

    Output
    The output of each test case of a line. If you can constitute an Integer which is satisfied above conditions, please output the biggest one. Otherwise, output "-1" instead.
     

    Sample Input
    3 0 1 3 3 5 4 2 3 2 4 6
     

    Sample Output
    301 425 -1
     

    Source
     

    Recommend
    heyang   |   We have carefully selected several similar problems for you:  5057 5056 5054 5053 5052 
    思路:这题有点略坑~思路挺简单。可是细心才干AC,

    直接将n个数排序。然后找最小的奇数移出就可以。

    PS:(1)要注意n==1的情况

              (2)You need to use this N Digits to constitute an Integer.

    #include <iostream>
    #include <stdio.h>
    #include <string.h>
    #include <string>
    #include <cmath>
    const int INF=99999999;
    #include <algorithm>
    using namespace std;
    
    int a[110];
    bool cmp(int a,int b)
    {
      return a>b;
    }
    int main()
    {
        int n;
        while(cin>>n)
        {
          for(int i=1;i<=n;i++)
          {
            cin>>a[i];
          }
         if(n==1)
         {
           if(a[1]&1)
                cout<<a[1]<<endl;
           else
                cout<<-1<<endl;
           continue;
         }
         sort(a+1,a+1+n,cmp);
    
         int flag=INF;
         for(int i=n;i>=1;i--)
         {
           if(a[i]&1)
           {
            flag=i;
            break;
           }
         }
         if(flag==INF)
         {
           cout<<-1<<endl;
           continue;
         }
         if(flag==1&&a[2]==0)
         {
           cout<<-1<<endl;
           continue;
         }
         for(int i=1;i<=n;i++)
         {
           if(i!=flag)
                cout<<a[i];
         }
         cout<<a[flag]<<endl;
        }
        return 0;
    }
    


  • 相关阅读:
    点击添加按钮添加一条记录,点击删除按钮删除本条记录
    两个input在一行让它们能对齐
    H5页面在微信中禁止下拉露出网页
    纯css实现隐藏滚动条仍可以滚动
    jQuery弹出层layer插件的使用
    flex组合流动布局实例---利用css的order属性改变盒子排列顺序
    媒体查询样式失效的解决办法
    menu-普通menu弹出框样式
    5lession-path路径相关操作
    do_pj--下拉代码脚本的使用
  • 原文地址:https://www.cnblogs.com/yxysuanfa/p/7340888.html
Copyright © 2020-2023  润新知