• poj 1426 Find The Multiple ( BFS+同余模定理)


    Find The Multiple
    Time Limit: 1000MS   Memory Limit: 10000K
    Total Submissions: 18390   Accepted: 7445   Special Judge

    Description

    Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.

    Input

    The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.

    Output

    For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.

    Sample Input

    2
    6
    19
    0

    Sample Output

    10
    100100100100100100
    111111111111111111


    同余模定理:

    (a*b)%n = (a%n *b%n)%n;

    (a+b)%n = (a%n +b%n)%n;

    枚举前14个数字为:1 、10 、11、100、101、110、111、1000、1001、1010、1011、1100、1101、1110。

    。。

    1110%6=(110*10+0)%6=((110%6)*10)%6+(0%6);

    mod[x]=(mod[x/2]*10+x%2)%n;

    #include<stdio.h>
    #define N 600000
    int mod[N];
    int ans[200];
    int main()
    {
        int i,k,n;
        while(scanf("%d",&n),n)
        {
            mod[1]=1%n; 
            for(i=2;mod[i-1]!=0;i++)
            {                    
                mod[i]=(mod[i/2]*10+i%2)%n;
            }
            i--;
            k=0;
            while(i)
            {
                ans[k++]=i%2;
                i/=2;
            }
            for(i=k-1;i>=0;i--)
                printf("%d",ans[i]);
            puts("");
        }
        return 0;
    }
    


  • 相关阅读:
    python--向钉钉群发送消息(亲测可用)
    python--注册钉钉回调事件(亲测可用)
    Gradle
    SpringBoot 中thymeleaf模板引擎的使用
    SpringBoot对静态资源的映射规则
    SpringBoot的日志使用
    rsync实现文件同步
    python学习: 优秀Python学习资源收集汇总--转
    Python高级特性: 12步轻松搞定Python装饰器
    Python常见问题
  • 原文地址:https://www.cnblogs.com/yxysuanfa/p/6903205.html
Copyright © 2020-2023  润新知