• POJ 3026 Borg Maze


    Borg Maze
    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 7998   Accepted: 2675

    Description

    The Borg is an immensely powerful race of enhanced humanoids from the delta quadrant of the galaxy. The Borg collective is the term used to describe the group consciousness of the Borg civilization. Each Borg individual is linked to the collective by a sophisticated subspace network that insures each member is given constant supervision and guidance. 

    Your task is to help the Borg (yes, really) by developing a program which helps the Borg to estimate the minimal cost of scanning a maze for the assimilation of aliens hiding in the maze, by moving in north, west, east, and south steps. The tricky thing is that the beginning of the search is conducted by a large group of over 100 individuals. Whenever an alien is assimilated, or at the beginning of the search, the group may split in two or more groups (but their consciousness is still collective.). The cost of searching a maze is definied as the total distance covered by all the groups involved in the search together. That is, if the original group walks five steps, then splits into two groups each walking three steps, the total distance is 11=5+3+3.

    Input

    On the first line of input there is one integer, N <= 50, giving the number of test cases in the input. Each test case starts with a line containg two integers x, y such that 1 <= x,y <= 50. After this, y lines follow, each which x characters. For each character, a space `` '' stands for an open space, a hash mark ``#'' stands for an obstructing wall, the capital letter ``A'' stand for an alien, and the capital letter ``S'' stands for the start of the search. The perimeter of the maze is always closed, i.e., there is no way to get out from the coordinate of the ``S''. At most 100 aliens are present in the maze, and everyone is reachable.

    Output

    For every test case, output one line containing the minimal cost of a succesful search of the maze leaving no aliens alive.

    Sample Input

    2
    6 5
    ##### 
    #A#A##
    # # A#
    #S  ##
    ##### 
    7 7
    #####  
    #AAA###
    #    A#
    # S ###
    #     #
    #AAA###
    #####  
    

    Sample Output

    8
    11


    最小生成树问题,主要是要求出点点距离,即字母间边权。这里用BFS求出了边权,用prim算法求出了最小生成树路径。



    AC代码例如以下:

    <pre name="code" class="cpp">#include<iostream>
    #include<queue>
    #include<cstring>
    #include<cstdio>
    #define inf 100000
    using namespace std;
    
    char map[60][60];
    int vis[60][60],v[60][60];
    int n,m,tt,ans;
    int dx[4]={-1,0,1,0};
    int dy[4]={0,1,0,-1};
    
    struct H
    {
        int h,z;
    }a[10005];
    
    int w[251][251],lc[251],vv[60][60];//W是边权记录,LCprim算法运用,VV记录第几个字母的坐标
    struct HH
    {
        int h,z,st;
    };
    
    int bfs(int h,int z)
    {
        int i;
        v[h][z]=1;
        queue <HH> q;
        HH a,b,c;
        a.h=h;
        a.z=z;
        a.st=0;
        q.push(a);
        while(!q.empty())
        {
            b=q.front();
            q.pop();
            if(vv[b.h][b.z])//统计边权
                {
                    w[vv[h][z]][vv[b.h][b.z]]=b.st;
                    w[vv[b.h][b.z]][vv[h][z]]=b.st;
                    //cout<<vv[h][z]<<" "<<vv[b.h][b.z]<<" "<<b.st<<endl;
                }
    
            for(i=0;i<4;i++)
            {
                c.h=b.h+dx[i];
                c.z=b.z+dy[i];
                if(c.h>=0&&c.h<n&&c.z>=0&&c.z<m&&map[c.h][c.z]!='#'&&!v[c.h][c.z])
                {
                    v[c.h][c.z]=1;
                    c.st=b.st+1;
                    q.push(c);
                }
            }
        }
    }
    
    void prim()
    {
        int i,j;
        int m,id;
        for(i=1;i<tt;i++)
        {
            lc[i]=w[1][i];
        }
    
        lc[1]=0;
        for(j=1;j<tt-1;j++)
        {
            m=inf;
            for(i=1;i<tt;i++)
            if(lc[i]!=0&&lc[i]<m)
            {m=lc[i];id=i;}
            ans+=m;
            lc[id]=0;
            for(i=1;i<tt;i++)
            {
                if(lc[i]!=0&&lc[i]>w[id][i])
                    lc[i]=w[id][i];
            }
        }
    
    }
    
    int main()
    {
        int i,j,l;
        int t;
        char c[10];
        scanf("%d",&t);
        gets(c);
        while(t--)
        {
            tt=1;
            memset(vis,0,sizeof vis );
            cin>>m>>n;
            gets(c);
            for(i=0;i<n;i++)
                gets(map[i]);
            //for(i=0;i<n;i++)
                //cout<<map[i]<<endl;
            int bj=0;
            memset(vv,0,sizeof vv);
            for(i=0;i<n;i++)
            {
                for(j=0;j<m;j++)
                if(map[i][j]=='A'||map[i][j]=='S')
                {
                    vv[i][j]=tt++;//记录字母序号及个数
                }
            }
            for(i=1;i<tt;i++)
                for(j=1;j<=i;j++)
                    if(i==j)
                    w[i][j]=0;
                    else {
                        w[i][j]=inf;
                        w[j][i]=inf;
                    }
            for(i=0;i<n;i++)
                for(j=0;j<m;j++)
                {
                    if((map[i][j]=='A'||map[i][j]=='S')&&!vis[i][j])
                    {
                        vis[i][j]=1;
                        memset(v,0,sizeof v);
                        bfs(i,j);//求出这个字母到各个字母产生的边权
                    }
    
                }
    
            ans=0;
            prim();//prim算法的运用
            cout<<ans<<endl;
        }
        return 0;
    }
    


    
       
    
  • 相关阅读:
    《你的知识需要管理》——田志刚
    《谁动了我的奶酪》——[美]斯宾塞·约翰逊
    《程序员面试宝典(第三版)》——欧立奇 / 刘洋 / 段韬
    《天才在左疯子在右》——高铭
    LintCode: Combination Sum
    LintCode: Flatten Binary Tree to Linked List
    LintCode: First Position of Target
    LintCode: Delete Node in the Middle of Singly Linked List
    LintCode: Maximum Depth of Binary Tree
    pytorch visdom可视化工具学习—3-命令行操作使用经验
  • 原文地址:https://www.cnblogs.com/yxwkf/p/5371441.html
Copyright © 2020-2023  润新知