• poj2586 Y2K Accounting Bug(贪心)


    转载请注明出处:http://blog.csdn.net/u012860063?viewmode=contents

    题目链接:http://poj.org/problem?id=2586

    ----------------------------------------------------------------------------------------------------------------------------------------------------------
    欢迎光临天资小屋害羞害羞害羞害羞http://user.qzone.qq.com/593830943/main
    
    
    ----------------------------------------------------------------------------------------------------------------------------------------------------------



    Language:
    Y2K Accounting Bug
    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 9979   Accepted: 4970

    Description

    Accounting for Computer Machinists (ACM) has sufferred from the Y2K bug and lost some vital data for preparing annual report for MS Inc. 
    All what they remember is that MS Inc. posted a surplus or a deficit each month of 1999 and each month when MS Inc. posted surplus, the amount of surplus was s and each month when MS Inc. posted deficit, the deficit was d. They do not remember which or how many months posted surplus or deficit. MS Inc., unlike other companies, posts their earnings for each consecutive 5 months during a year. ACM knows that each of these 8 postings reported a deficit but they do not know how much. The chief accountant is almost sure that MS Inc. was about to post surplus for the entire year of 1999. Almost but not quite. 

    Write a program, which decides whether MS Inc. suffered a deficit during 1999, or if a surplus for 1999 was possible, what is the maximum amount of surplus that they can post.

    Input

    Input is a sequence of lines, each containing two positive integers s and d.

    Output

    For each line of input, output one line containing either a single integer giving the amount of surplus for the entire year, or output Deficit if it is impossible.

    Sample Input

    59 237
    375 743
    200000 849694
    2500000 8000000
    

    Sample Output

    116
    28
    300612
    Deficit


    题意比較难懂,事实上仅仅要读懂题意,就非常easy了。
    大意是一个公司在12个月中,或固定盈余s,或固定亏损d.
    但记不得哪些月盈余,哪些月亏损,仅仅能记得连续5个月的代数和总是亏损(<0为亏损),而一年中仅仅有8个连续的5个月,分别为1~5,2~6,…,8~12
    问全年是否可能盈利?若可能,输出可能最大盈利金额,否则输出“Deficit".

    思路:贪心思想,每连续5个月中,在保证这5个月经营之和为亏损的情况下,亏损的月数肯定应尽量往后选,盈利的月数应尽量往前选。

    一共五种情况:

    把5种情况能够归纳为关于s的判定条件:

    0 <= s <1/4d           每连续5个月种至少1个月D

    1/4d <= s < 2/3d          每连续5个月种至少2个月D

    2/3d <= s < 3/2d          每连续5个月种至少3个月D

    3/2d <= s < 4d           每连续5个月种至少4个月D

    4d <= s                全年各月必亏损

    代码例如以下:

    #include <iostream>
    using namespace std;
    int main()
    {
    	int s, d, flag;
    	while(cin>>s>>d)
    	{
    		int sum = 0;
    		flag = 0;
    		if(0<=s && s<(1.0/4)*d)
    		{
    			sum = 10*s - 2*d;
    		}
    		else if((1.0/4)*d<=s && s<(2.0/3)*d)
    		{
    			sum = 8*s-4*d;
    		}
    		else if((2.0/3)*d<=s && s<(3.0/2)*d)
    		{
    			sum = 6*s-6*d;
    		}
    		else if((3.0/2)*d<=s && s<4*d)
    		{
    			sum = 3*s-9*d;
    		}
    		else if(4*d <= s)
    		{
    			flag = 1;
    		}
    		if( sum < 0)
    			flag = 1;
    		if(flag)
    			cout<<"Deficit"<<endl;
    		else
    			cout<<sum<<endl;
    	}
    	return 0;
    }



                        

  • 相关阅读:
    Spring模板方法模式及Callback
    vc新线程、类外控制EDIT控件
    OpenGL绘制框架
    回调函数c++
    matlab练习程序(求灰度图像最大灰度,最小灰度,平均灰度)
    OpenGL绘制函数
    matlab练习程序(图像傅里叶变换,幅度谱,相位谱)
    多项式系数提取算法 c++
    OpenGL绘制复杂图形
    matlab练习程序(图像加噪,各种滤波)
  • 原文地址:https://www.cnblogs.com/yxwkf/p/3860112.html
Copyright © 2020-2023  润新知