• POJ-3268-最短路(dijkstra算法)


    Silver Cow Party

    Time Limit: 2000MS   Memory Limit: 65536K
    Total Submissions: 12494   Accepted: 5568

    Description

    One cow from each of N farms (1 ≤ N ≤ 1000) conveniently numbered 1..N is going to attend the big cow party to be held at farm #X (1 ≤XN). A total of M (1 ≤ M ≤ 100,000) unidirectional (one-way roads connects pairs of farms; roadi requires Ti (1 ≤ Ti ≤ 100) units of time to traverse.

    Each cow must walk to the party and, when the party is over, return to her farm. Each cow is lazy and thus picks an optimal route with the shortest time. A cow's return route might be different from her original route to the party since roads are one-way.

    Of all the cows, what is the longest amount of time a cow must spend walking to the party and back?

    Input

    Line 1: Three space-separated integers, respectively:N, M, and X
    Lines 2..M+1: Line i+1 describes road i with three space-separated integers:Ai, Bi, and Ti. The described road runs from farmAi to farm Bi, requiring Ti time units to traverse.

    Output

    Line 1: One integer: the maximum of time any one cow must walk.

    Sample Input

    4 8 2
    1 2 4
    1 3 2
    1 4 7
    2 1 1
    2 3 5
    3 1 2
    3 4 4
    4 2 3

    Sample Output

    10

    Hint

    Cow 4 proceeds directly to the party (3 units) and returns via farms 1 and 3 (7 units), for a total of 10 time units.

    Source

    USACO 2007 February Silver

    题目的意思是:从出发点到达目的地X。再从X返回到出发点的最短路径中的最大值(由于出发点没有固定,也就是能够:1->X->1, 2->X->2等)

    所以我们要枚举全部的可能性。找出当中的最大值。

    巧妙地运用dijkstra算法,双向求出两次X->m的最短路径长然后相加即得到了m->X->m的最短路径。代码例如以下:

    #include<queue>
    #include<vector>
    #include<stdio.h>
    #include<string.h>
    #include<iostream>
    #include<algorithm>
    using namespace std;
    struct Edge
    {
        int to;
        int dis;
        Edge(int to, int dis){
            this -> to = to;
            this -> dis = dis;
        }
    };
    typedef pair<int,int>P;
    
    int a,b,c;
    int N,M,X;
    int d1[1005],d2[1005];
    vector<Edge> G1[1005];
    vector<Edge> G2[1005];
    void dijkstra(int s,int d[],vector<Edge> G[])
    {
        priority_queue<P,vector<P>,greater<P> >q;
        d[s]=0;
        q.push(P(0,s));
        while(q.size())
        {
            P p=q.top();
            q.pop();
            int v=p.second;
            for(int i=0;i<G[v].size();i++)
            {
                Edge& e=G[v][i];
                if(d[e.to]>d[v]+e.dis)
                {
                    d[e.to]=d[v]+e.dis;
                    q.push(P(d[e.to],e.to));
                }
            }
        }
    }
    int main()
    {
        memset(d1,0x5f,sizeof(d1));
        memset(d2,0x5f,sizeof(d2));
        scanf("%d%d%d",&N,&M,&X);
        for(int i=1;i<=M;i++)
        {
            scanf("%d%d%d",&a,&b,&c);
            G1[a].push_back(Edge(b,c));
            G2[b].push_back(Edge(a,c));
        }
        dijkstra(X,d1,G1);
        dijkstra(X,d2,G2);
        int small_max=-1;
        for(int i=1;i<=N;i++)
        {
            if(i==X) continue;
            small_max=max(small_max,d1[i]+d2[i]);
        }
        cout<<small_max<<endl;
    }
    


  • 相关阅读:
    fastjson对象,JSON,字符串,map之间的互转
    bootstrap的页面刷新以及模态框的清空
    change 和 propertychange 事件监听input 并发起ajax请求
    jquery 获取和设置select的option值
    Mybatis中使用@Select注解进行模糊查询,使用concat关键字
    mysql 获取表字段及注释
    SpringBoot 在IDEA中实现热部署
    jquery与css控制元素的隐藏和显示的几种方法
    Java8 stream的详细用法
    FATAL ERROR: Could not find ./bin/my_print_defaults 解决方法
  • 原文地址:https://www.cnblogs.com/yutingliuyl/p/7137910.html
Copyright © 2020-2023  润新知