• hdu 1701 (Binary Tree Traversals)(二叉树前序中序推后序)


                                                                                Binary Tree Traversals
    Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u
    Submit Status

    Description

    A binary tree is a finite set of vertices that is either empty or consists of a root r and two disjoint binary trees called the left and right subtrees. There are three most important ways in which the vertices of a binary tree can be systematically traversed or ordered. They are preorder, inorder and postorder. Let T be a binary tree with root r and subtrees T1,T2.

    In a preorder traversal of the vertices of T, we visit the root r followed by visiting the vertices of T1 in preorder, then the vertices of T2 in preorder.

    In an inorder traversal of the vertices of T, we visit the vertices of T1 in inorder, then the root r, followed by the vertices of T2 in inorder.

    In a postorder traversal of the vertices of T, we visit the vertices of T1 in postorder, then the vertices of T2 in postorder and finally we visit r.

    Now you are given the preorder sequence and inorder sequence of a certain binary tree. Try to find out its postorder sequence.
     

    Input

    The input contains several test cases. The first line of each test case contains a single integer n (1<=n<=1000), the number of vertices of the binary tree. Followed by two lines, respectively indicating the preorder sequence and inorder sequence. You can assume they are always correspond to a exclusive binary tree.
     

    Output

    For each test case print a single line specifying the corresponding postorder sequence.
     

    Sample Input

    9
    1 2 4 7 3 5 8 9 6
    4 7 2 1 8 5 9 3 6
     

    Sample Output

    7 4 2 8 9 5 6 3 1
     
    不知道为什么往函数里串地址就运行不了,找了半天没找到错误!
     这是错误的代码:
    #include <stdio.h>  
    #include <string.h>  
    int n;
    int a[1000], b[1000], c[1000]; 
    
    
    void build( int len, int s1, int s2, int s )  
    {  
        int p;  
        int i;  
        if(len<=0)  
            return;  
        else  
        {  
            for(i=s2; i<s2+len; i++ )  
            {  
                if(b[i]==a[s1])  
                {  
                    p = i;  
    				break;
                }  
            }  
    		 c[s+len-1] = a[s1]; 
    
            build(p, s1+1, s2, s );  //左
            build(len-p-1, s1+p+1, s2+p+1, s+p);  //右
            
        }  
    }  
    int main()  
    {  
         int i, j;
         while(scanf("%d", &n)!=EOF)
    	 {
    		 for(i=0; i<n; i++)
    		 {
    			 scanf("%d", &a[i] );
    		 }
    		 for(i=0; i<n; i++)
    		 {
    			 scanf("%d", &b[i] );
    		 }
    		 build(n, 0, 0, 0);
    	
    	    for(i=0; i<n; i++)
    		{
    		   printf("*%d ", c[i] );
    		}
    	 }
    	
        
    	return 0;
    }   
      
    
     
    这是正确的代码:
     
    #include <stdio.h>  
    #include <string.h>  
    void build(int len, int *s1, int *s2, int *s)  
    {  
        int p;  
        int i;  
        if(len<=0)  
            return;  
      
        else  
        {  
            for(i=0; i<len; i++)  
            {  
                if(s2[i]==s1[0])  
                {  
                    p = i;  
                }  
            }  
            build(p, s1+1, s2, s);  
            build(len-p-1, s1+p+1, s2+p+1, s+p);  
            s[len-1] = s1[0];  
        }  
    }  
    int main()  
    {  
    	int i;
    
        int s1[1000], s2[1000], s3[1000];  
        int n;
    	while(scanf("%d", &n)!=EOF)
    	{
    		for(i=0; i<n; i++)
    		 {
    			 scanf("%d", &s1[i] );
    		 }
    		 for(i=0; i<n; i++)
    		 {
    			 scanf("%d", &s2[i] );
    		 }
    		 build(n, s1, s2, s3 );
    		 for(i=0; i<n; i++)
    		 {
    			 printf("%d%c", s3[i], i==n-1?'
    ':' ' );
    		 }
    	}
      
    	return 0;
    }   
      
      
    
  • 相关阅读:
    TextView 内容设置成上下滑动 和 代码设置字体颜色
    Android提供了4种在其他线程中访问UI线程的方法
    Android 左右滑屏效果
    【自定义控件】 GridView
    【动画】【特效】activity跳转华丽的过渡效果(转载)
    Android获取设备型号、SDK版本及其系统版本
    【JSON】数据解析
    Android中文API集合
    【AssetManager】的使用与资源预加载
    @property(nonatomic,retain)
  • 原文地址:https://www.cnblogs.com/yspworld/p/3881534.html
Copyright © 2020-2023  润新知