• 1024 Palindromic Number (25)(25 point(s))


    problem

    A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.
    
    Non-palindromic numbers can be paired with palindromic ones via a series of operations. First, the non-palindromic number is reversed and the result is added to the original number. If the result is not a palindromic number, this is repeated until it gives a palindromic number. For example, if we start from 67, we can obtain a palindromic number in 2 steps: 67 + 76 = 143, and 143 + 341 = 484.
    
    Given any positive integer N, you are supposed to find its paired palindromic number and the number of steps taken to find it.
    
    Input Specification:
    
    Each input file contains one test case. Each case consists of two positive numbers N and K, where N (<= 10^10^) is the initial numer and K (<= 100) is the maximum number of steps. The numbers are separated by a space.
    
    Output Specification:
    
    For each test case, output two numbers, one in each line. The first number is the paired palindromic number of N, and the second number is the number of steps taken to find the palindromic number. If the palindromic number is not found after K steps, just output the number obtained at the Kth step and K instead.
    
    Sample Input 1:
    
    67 3
    Sample Output 1:
    
    484
    2
    Sample Input 2:
    
    69 3
    Sample Output 2:
    
    1353
    3
    

    tip

    answer

    #include<iostream>
    
    #define LL long long
    using namespace std;
    
    LL num, Time;
    
    
    LL Palin(LL a){
    	LL b = 0, t = 0;
    	t = a;
    	while(t > 0){
    		b *= 10;
    		b += t%10;
    		t /= 10;
    	}
    	return b;
    }
    
    LL Add(LL a, LL &t){
    	t++;
    	return a+Palin(a);
    }
    
    
    int main() {
    //	freopen("test.txt", "r", stdin);
    	scanf("%lld%lld", &num, &Time);
    	LL t = 0;
    	if(num == 0) {
    		printf("0
    0");
    		return 0; 
    	}
    	LL tn = num;
    	while(tn != Palin(tn)){
    		tn = Add (tn, t);
    		if(t >= Time) break;
    	} 
    	printf("%lld
    %lld", tn, t);
    	return 0;
    }
    

    experience

    • Palindromic 回文的

    • pat 的判题器不支持long long I64d, 支持lld, printf时应该使用 lld。

  • 相关阅读:
    java.lang.Class
    公司面试题目之取出数据库中重复的记录
    常用的linux基础命令
    算法练习4冒泡排序java版
    算法练习1桶排序java版
    算法练习2斐波那契数列java版
    算法练习3水仙花数java版
    mysql查询语句复习小结
    linux设置开机自动进入命令模式
    JSP九大内置对象和四个作用域
  • 原文地址:https://www.cnblogs.com/yoyo-sincerely/p/9332751.html
Copyright © 2020-2023  润新知