• 1008 Elevator (20)(20 point(s))


    problem

    The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.
    
    For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.
    
    Input Specification:
    
    Each input file contains one test case. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100.
    
    Output Specification:
    
    For each test case, print the total time on a single line.
    
    Sample Input:
    
    3 2 3 1
    Sample Output:
    
    41
    

    tip

    求电梯载上所有人时,所花时间。

    answer

    #include<bits/stdc++.h>
    using namespace std;
    
    #define INF 0x3f3f3f3f
    
    int n;
    
    int main(){
    //	freopen("test.txt", "r", stdin);
    	cin>>n;
    	int last = 0, now = 0, time = 0;
    	for(int i = 0; i < n; i++){
    		cin>>now;
    		int del = now - last;
    		if(del == 0) time += 5;
    		else if(del > 0){
    			time += del * 6 + 5;
    		}
    		else {
    			del = abs(del);
    			time += del * 4 + 5;
    		}
    		last = now; 
    	}
    	cout<<time;
    	return 0;
    }
    

    experience

    • 边界条件 del == 0时,还要等5秒
  • 相关阅读:
    分布式训练基本原理
    服务化部署框架Paddle Serving
    Paddle Inference原生推理库
    源码编译优化
    推理部署概述
    深度学习模型组网
    在这里
    什么是响应式编程,为什么使用它?
    时间管理:如何充分利用你的24小时-吉姆·兰德尔.pdf
    Win10激活工具
  • 原文地址:https://www.cnblogs.com/yoyo-sincerely/p/9270518.html
Copyright © 2020-2023  润新知