• 1007 Maximum Subsequence Sum (25)(25 point(s))


    problem

    Given a sequence of K integers { N~1~, N~2~, ..., N~K~ }. A continuous subsequence is defined to be { N~i~, N~i+1~, ..., N~j~ } where 1 <= i <= j <= K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.
    
    Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.
    
    Input Specification:
    
    Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (<= 10000). The second line contains K numbers, separated by a space.
    
    Output Specification:
    
    For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.
    
    Sample Input:
    
    10
    -10 1 2 3 4 -5 -23 3 7 -21
    Sample Output:
    
    10 1 4
    

    tip

    求最大子序列和。

    anwser

    #include<bits/stdc++.h>
    using namespace std;
    
    #define Max 10001
    #define INF 0x3f3f3f3f
    
    int K, num[Max], neg = 0;
    
    int main(){
    //	freopen("test.txt", "r", stdin);
    	cin>>K;
    	for(int i = 0; i < K; i++){
    		cin>>num[i];
    		if(num[i] < 0) neg++;
    	}
    	
    	int sum = 0, firstIndex = 0, lastIndex = K-1, maxSum = 0, temp = 0;
    	for(int i = 0; i < K; i++){
    		sum += num[i];
    		if(maxSum < sum || (sum == 0 && lastIndex == K-1)) {
    			maxSum = sum;
    			temp = firstIndex;
    			lastIndex = i;
    		}
    		if(sum <= 0){
    			sum = 0;
    			firstIndex = i+1;
    		}
    	}
    	if(neg == K) {
    		temp = 0;
    		lastIndex = K-1;
    	}
    	cout<<maxSum<<" "<<num[temp]<<" "<<num[lastIndex];
    	return 0;
    }
    
    /*
    10
    -10 1 2 3 4 -5 -23 3 7 -21
    */
    

    experience

    • 数据有毒。
      • 所有数都为正的情况,以及0与负数的情况,有点冲突。
  • 相关阅读:
    1.1.28 文字所在段落增加下划线
    Microsoft Project 2010基础使用方法
    16.3 将Win7文档的内容到复制Linux的vi中
    3.4 在Word中的公式和序号之间填充连续的点
    18.25 JLink调试程序步骤
    18.24 Ubuntu修改静态IP
    18.23 inline函数功能
    18.22 sprintf函数功能
    18.21 关键字extern
    18.20 频率单位转换
  • 原文地址:https://www.cnblogs.com/yoyo-sincerely/p/9265663.html
Copyright © 2020-2023  润新知