• 11572


     Emily the entrepreneur has a cool business idea: packaging and selling snowflakes. She has devised a machine that captures snowflakes as they fall, and serializes them into a stream of snowflakes that flow, one by one, into a package. Once the package is full, it is closed and shipped to be sold. The marketing motto for the company is “bags of uniqueness.” To live up to the motto, every snowflake in a package must be different from the others. Unfortunately, this is easier said than done, because in reality, many of the snowflakes flowing through the machine are identical. Emily would like to know the size of the largest possible package of unique snowflakes that can be created. The machine can start filling the package at any time, but once it starts, all snowflakes flowing from the machine must go into the package until the package is completed and sealed. The package can be completed and sealed before all of the snowflakes have flowed out of the machine.
    Input
    The first line of input contains one integer specifying the number of test cases to follow. Each test case begins with a line containing an integer n, the number of snowflakes processed by the machine. The following n lines each contain an integer (in the range 0 to 109, inclusive) uniquely identifying a snowflake. Two snowflakes are identified by the same integer if and only if they are identical. The input will contain no more than one million total snowflakes.
    Output
    For each test case output a line containing single integer, the maximum number of unique snowflakes that can be in a package.
    Sample Input
    1 5 1 2 3 2 1
    Sample Output
    3

    分析:

    从一个有n个数的序列中,找到一个最大的子段(连续的),使得这个最大子段中没有重复元素,输出最大子段的长度。

    注意:序列是不连续的,子段必须是连续的

    做法:

    对于该类段查找问题可以采用经典的滑动窗口方法,即维护一个窗口,窗口的左右边界用两个变量L,R代表,先增加R直到出现重复数字,再增加L,再增加R,直到R达到n

    贴张图形象得一批~

    set好用!

    code:

    #include<stdio.h>
    #include <iostream>
    #include <math.h>
    #include <queue>
    #include<set>
    using namespace std;
    #define max_v 1000005
    int a[max_v];
    int main()
    {
        set<int> s;
        int t,n;
        cin>>t;
        while(t--)
        {
            cin>>n;
            for(int i=0;i<n;i++)
                cin>>a[i];
            s.clear();
            int left=0,right=0,ans=0;
            while(right<n)
            {
                while(right<n&&!s.count(a[right]))
                {
                    s.insert(a[right++]);
                }
                ans=max(ans,right-left);
                s.erase(a[left++]);
            }
            cout<<ans<<endl;
        }
        return 0;
    }
  • 相关阅读:
    数据对齐
    算法面试题集——从各大博客收集
    软件工程师规划
    链栈,顺序栈,单链队列,循环队列,非循环队列的简单实现
    C,C++文件和目录操作的一些整理
    WPF使用笔记-计时器,多线程更新界面,焦点移动等
    Heap Data Structure and Heap Sort
    YUV420P像素数据编码为JPEG图片
    根据txt文件中指定的文件名进行文件分类
    MFC显示图片和写入文件
  • 原文地址:https://www.cnblogs.com/yinbiao/p/9397004.html
Copyright © 2020-2023  润新知